I have a question Confusing issue - No power steering / car dying - Club4G Forum : Mitsubishi Eclipse 4G Forums - 2006-2012 Eclipse Authority
Support Our Troops!         
 

Go Back   Club4G Forum : Mitsubishi Eclipse 4G Forums - 2006-2012 Eclipse Authority > General > 2000-2005 Eclipse (General 3G)

2000-2005 Eclipse (General 3G) General discussion and information about 2000~2005 (3rd Generation) Eclipse

Reply
 
LinkBack Thread Tools Display Modes
Old November 4th, 2017, 02:15 PM   #1 (permalink)
Junior Member
 

Name: Andrew
Join Date: Nov 2017
Location: United States
Posts: 1
Rep Power: 3
trippysheep94 is on a distinguished road
Exclamation Confusing issue - No power steering / car dying

2003 Mitsubishi Eclipse GTS ( 6g72 )
108,XXX Miles

I was noticing some weird noises this last week when I would turn. Had wrote it off as ball bearings and ordered the part. This did not fix the issue as last night my power steering completely died as did the car. Power steering started getting stiff as I pulled into a parking lot followed by my brake ( not abs ) and battery light coming on. After a few moments I noticed a weird chirping noise as if a belt had slipped off but after inspecting, this wasn't the case.

There is not one single belt on the 6g72 engine that runs both the alternator and the PS Pump so I was confused as to how these both could go out at the same time. I have replaced the entire electrical system in the car as well as doing a timing job recently. I am entirely lost as to what the issue could be.

I'm thinking the ps pump went bad, but if this is so, why would it also be killing my car seeing as how the pump is on a seperate belt than my alternator?
This leads me to believe it is an electrical problem with the power steering pump not being an issue but just being affected by the loss of power at some point. What could be causing this when I just replaced basically my entire elec system. I have also checked and my alt fuse is intact as well as all of my other fuses.

- Both belts are fine and have been replaced within 5k miles as well as the timing belt.
-New fuseable link
- New alternator
- New tensioner pulleys
- New battery

Last edited by trippysheep94; November 4th, 2017 at 02:17 PM.
trippysheep94 is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old November 4th, 2017, 05:11 PM   #2 (permalink)
Basically Stock
 
Sabertooth^2's Avatar
You'll probably get better help on a forum for your car

Club3G Forum : Mitsubishi Eclipse 3G Forums - The Original 2000+ Eclipse Authority

A 3000gt/stealth/gto forum may also be helpful, as they use the 6g72 as well
__________________
Photobucket p500 fix

My Build Thread


Find me at 4G World
Sabertooth^2 is offline   Reply With Quote Quick reply to this message
Old November 4th, 2017, 07:32 PM   #3 (permalink)
Junior Member
 

Name: Nate
Join Date: Dec 2015
Location: Pittsburgh
Vehicle: 2012 Eclipse GS auto
Posts: 22
Rep Power: 5
np30524 is on a distinguished road
Like Sabertooth said the best place to find an answer is probably the Club3G group, but if i might offer a suggestion. I have very little experience with a 6G72 motor but i work with other cars that are a duel drive belt set up everyday. Since you said you have replaced the drive belts i would suggest to go back and check that the tension on them is not set to tight.

The reason is even though the power steering pump and the alternator are not driven by the same belt, they are linked to each other by the crankshaft. If the tension is set to tight on both of them then a failing power steering pump can slow down the crankshaft in turn slowing the alternator, and in extreme cases completely stalling the car. The reason i say this is that this car does not use hydraulic or spring loaded tensioner, Instead it uses static ones that have to be adjusted periodically by hand. Hope this helps
np30524 is offline   Reply With Quote Quick reply to this message
Reply

Tags
abs, alternator, bad, ball, battery, belt, brake, car, eclipse, electrical, engine, fix, issue, light, mitsubishi, mitsubishi eclipse, noises, power, power steering, pump, single, stiff, system, timing, tire

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Club4G Forum : Mitsubishi Eclipse 4G Forums - 2006-2012 Eclipse Authority forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
Real Name
What name do you go by?
Location
Where you live.
Type of Car
Year/Model/Trim
Insurance
Please select your insurance company (Optional)

Log-in



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Electric Power Steering Conversion? (just hypothesizing) #TampaEclipse 4G Eclipse GT/SE Specific 13 January 29th, 2018 01:04 AM
Clutch and power steering pump! OriginalCarPost 2006-2012 Eclipse (General 4G) 5 May 3rd, 2017 11:05 PM
Minor Steering Play Issue Porcupinepuffer Problem Reports 1 November 30th, 2016 11:07 AM
2003 Mitsubishi Eclipse GTS-Performance/Show Car Joe17269 Cars For Sale/Wanted 3 December 24th, 2015 06:12 AM


All times are GMT -5. The time now is 02:14 PM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Search Engine Friendly URLs by vBSEO
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
Ad Management plugin by RedTyger