Bad Fishtail - Club4G Forum : Mitsubishi Eclipse 4G Forums - 2006-2012 Eclipse Authority
Support Our Troops!         
 

Go Back   Club4G Forum : Mitsubishi Eclipse 4G Forums - 2006-2012 Eclipse Authority > General > 2000-2005 Eclipse (General 3G)

2000-2005 Eclipse (General 3G) General discussion and information about 2000~2005 (3rd Generation) Eclipse


Welcome to the Club4G Forums where you can join fellow owners from all over North America discussing anything related to the 2006+ Mitsubishi Eclipse. You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. To gain access to post topics, communicate privately with other members (PM), respond to polls, upload content, you must register today!

  • Participate in over 100 specialized forums!
  • Get event information regarding meets, mod days and help in our regionalized forums.
  • Gain access to our classified marketplace to buy, sell or trade parts.
  • Levarage a vast collection of Do-It-Yourself guides on steps on working on your Eclipse
  • Access to the growing online parts directory which gives you insight on available parts and the vendors that carry them.
  • Communicate privately with other owners.

All of this and much more is available to you absolutely free when you register for an account. Sign up today!

If you have any problems with the registration process or your account login, please contact contact us.
Reply
 
LinkBack Thread Tools Display Modes
Old November 23rd, 2015, 09:59 PM   #1 (permalink)
Junior Member
 

Name: Marshall
Join Date: Oct 2015
Location: Missouri
Vehicle: 2004/Eclipse/GTS
Posts: 2
Rep Power: 5
heatman72 is on a distinguished road
Bad Fishtail

I need some input from folks that have owned a 2004 GTS Coupe. I recently purchased a 2004 GTS Coupe and it wanted to go everywhere in the rain, I replaced all four tires a couple days ago (rear ones were bald) and now even on dry pavement when I hit a small bump the car feels like there is a large ball under the center. Any suggestions would be great, I do know the rear struts are leaking and most likely completely discharged of dampening fluid. I'm wondering if the lower rearward control arms (ones with ball joint) are worn out.
heatman72 is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old November 23rd, 2015, 11:01 PM   #2 (permalink)
Basically Stock
 
Sabertooth^2's Avatar
Have you tried the 3g forum?
Club3G Forum : Mitsubishi Eclipse 3G Forums

I'm not saying you're not welcome here by any means, just they have more experience to the 3g specific
__________________
Photobucket p500 fix

My Build Thread


Find me at 4G World
Sabertooth^2 is online now   Reply With Quote Quick reply to this message
Old November 30th, 2015, 04:41 PM   #3 (permalink)
Senior Member
 

Join Date: Aug 2009
Location: North Pole Alaska
Vehicle: 07 Eclipse GT 6speed
Posts: 627
Rep Power: 11
skysky has a spectacular aura about
It might be you're alignment. If your camber is uneven between left and right too much, or just waaayyy too much, it will tram line on you. A bump will upset the contact patch and lean the car on one side or the other, or the excess camber will grab the driving grooves or cracks beat into the surface and will follow them. Also if your Toe is out of whack it will get squirly as the tires break free then grab as they are "cupping" down the road, imaging it as tiny bouncing that is just enough to break traction to reset the tire then repeating.

As far as the the struts, if they're blown they would give you a bouncy ride and it would take a while for the car to settle after each bump. They also contribute to controlling the weight transfer and suspension action and could be exascerbating the problem.

I would replace your struts with oem equivalents then get an alignment. It should clear stuff up and make the car more confident and SAFE for you and others
__________________
Injen intake, RRE short tube headers, Injen exhaust, Outlaw Engineering spacers, Quaife LSD, CM fx350 with steel FW, ViS CF OEM hood, XXR 527 wheels, Conti. Extr. Cont. DW 245/45/18 tires, Progress sway bar, Energy Suspension motor mounts and suspension bushings, RRE shifter bushings, Tanabe strut brace, MR coilovers, AEM FIC.
skysky is offline   Reply With Quote Quick reply to this message
 
Old November 30th, 2015, 05:09 PM   #4 (permalink)
resident crossplatformer
 
fox_brand's Avatar
 

Name: -
Join Date: Aug 2011
Location: Chicago Suburbs
Vehicle: 1999 Galant
Posts: 1,377
Rep Power: 10
fox_brand is a jewel in the roughfox_brand is a jewel in the rough
I will personally say with the 3g Eclipse/8g Galant platform, if the car is lowered (in my case, highest ride height BC coilovers, which is something like 1.5 inches lower than stock), the rear tires will have more camber than the front if you keep the front alignment and don't correct the rear, this will make the rears wear faster and oversteer friendly (and that is why I lost 3 years of my life last winter, I am including this as experience I have had with something similar)

as for the control arms, it is possible, the rear shocks are psudo struts, there is no hinge at the top of the shock and there is a joint at the bottom of the shock, even while the rear is multi link, it is possible that a bad lower joint with the control arm could exacerbate normal wear with the shock (thus the leak unless those are the factory shocks, which, just wow). When you are doing the shocks check those joints while the car is in the air, grab the control arm (with the shocks out) and pull and push with about as much force it takes to tighten your oil drain plug (about as comfortable as I am with pushing and pulling on the car on jack stands) to check for play

Last edited by fox_brand; December 15th, 2015 at 02:30 PM. Reason: grammer
fox_brand is offline   Reply With Quote Quick reply to this message
Old December 1st, 2015, 07:23 PM   #5 (permalink)
Junior Member
 

Name: Thayne
Join Date: Jan 2014
Location: ATX
Vehicle: 2001 Eclipse GTP
Posts: 26
Rep Power: 7
detter21 is on a distinguished road
I would check the rear joints, mostly the trailing arm and the upper control arm of the rear. These tend to have play and could give you the rear squabble I think you are feeling. They are #4 and #11 in the picture.

6227870.gif

http://mitsubishiparts.net/media/ima.../6/6227870.gif

Also, check your tires pressures. I know they are knew but you never know.
detter21 is offline   Reply With Quote Quick reply to this message
Old December 12th, 2015, 07:48 PM   #6 (permalink)
Junior Member
 

Name: Marshall
Join Date: Oct 2015
Location: Missouri
Vehicle: 2004/Eclipse/GTS
Posts: 2
Rep Power: 5
heatman72 is on a distinguished road
Thanks for the advice, after getting under it I found the passenger side lower forward control arm outter mounting bolt to be loose. The person I purchased the vehicle from must have done part replacement and forgot to tighten it, I replaced the bolt and nut and tightened to spec, and the car drives like I would expect it to.
heatman72 is offline   Reply With Quote Quick reply to this message
Old December 15th, 2015, 07:41 AM   #7 (permalink)
Junior Member
 

Name: Thayne
Join Date: Jan 2014
Location: ATX
Vehicle: 2001 Eclipse GTP
Posts: 26
Rep Power: 7
detter21 is on a distinguished road
Good to hear.
detter21 is offline   Reply With Quote Quick reply to this message
Old December 18th, 2015, 11:23 PM   #8 (permalink)
Senior Member
 
Rob Z's Avatar
 

Name: Rob
Join Date: Jun 2011
Location: Texarkana, TX
Vehicle: 2006/Eclipse/GT
Posts: 1,297
Rep Power: 10
Rob Z is just really niceRob Z is just really niceRob Z is just really nice
Ivr been activly racing mine for three years in the SCCA SOLO (autocross) series. Ive only managed to break my rearend loose once in all those races. Set right our cars rear does not come loose. I wish mine did sometimes
__________________
Current Mods = Full Plasti Dip, Stiffy, Full Poly Mounts, Short Shifter, Full open exhaust, Outlaw Spacers, 4 point cage, CAI, k/n filter, BC Coilovers, Custom Rear sway bar, Slotted Rotors, Ceramic pads, Braided Break lines, 4 point harness, Stage 3 clutch, Custom tune
Rob Z is offline   Reply With Quote Quick reply to this message
Old December 19th, 2015, 06:05 PM   #9 (permalink)
Senior Member
 
Plain Jane's Avatar
 

Name: Martino
Join Date: Feb 2015
Location: Montreal
Vehicle: 2007 Eclipse GT
Posts: 1,702
Rep Power: 7
Plain Jane is a jewel in the roughPlain Jane is a jewel in the rough
Quote:
Originally Posted by Rob Z View Post
Ivr been activly racing mine for three years in the SCCA SOLO (autocross) series. Ive only managed to break my rearend loose once in all those races. Set right our cars rear does not come loose. I wish mine did sometimes
My rear end came out chasing a Cadi ATS 3.6 on a circular highway offramp. Caught me by surprise, luckily getting off the throttle and counter steering a little brought it back in line. Yes, these chassis are more susceptible to understeer, but oversteer can still happen when pushed hard enough.

I was running 40psi in the rear tires at the time, because economy lol
__________________
'07 GT build thread - 280whp, 254wtq

Last edited by Plain Jane; December 19th, 2015 at 06:15 PM.
Plain Jane is offline   Reply With Quote Quick reply to this message
Old December 22nd, 2015, 09:41 PM   #10 (permalink)
Senior Member
 
Rob Z's Avatar
 

Name: Rob
Join Date: Jun 2011
Location: Texarkana, TX
Vehicle: 2006/Eclipse/GT
Posts: 1,297
Rep Power: 10
Rob Z is just really niceRob Z is just really niceRob Z is just really nice
40psi well there's your problem

But i still maintain that properly set our cars are almost impossible to fishtail. But again that's good tires with proper air and good suspension all round.

I've taken 1st for two years in SCCA SOLO so trust me when i say I've driven mine HARD into and out of corners. In all those races ive only had the ass break loose once and that was wet.

Higher tire pressure might give a lower rolling resistance but the sacrifice in performance and handeling is not worth it. You ate upsetting the cars geometry and making it unpredictable.
__________________
Current Mods = Full Plasti Dip, Stiffy, Full Poly Mounts, Short Shifter, Full open exhaust, Outlaw Spacers, 4 point cage, CAI, k/n filter, BC Coilovers, Custom Rear sway bar, Slotted Rotors, Ceramic pads, Braided Break lines, 4 point harness, Stage 3 clutch, Custom tune
Rob Z is offline   Reply With Quote Quick reply to this message
Old January 11th, 2016, 08:42 AM   #11 (permalink)
Senior Member
 
Plain Jane's Avatar
 

Name: Martino
Join Date: Feb 2015
Location: Montreal
Vehicle: 2007 Eclipse GT
Posts: 1,702
Rep Power: 7
Plain Jane is a jewel in the roughPlain Jane is a jewel in the rough
Yup, lesson learned. I didn't buy a Prius so I shouldn't bother with that Greenpeace economy crap lol

What tire pressure do you race at?
__________________
'07 GT build thread - 280whp, 254wtq

Last edited by Plain Jane; January 11th, 2016 at 09:01 AM.
Plain Jane is offline   Reply With Quote Quick reply to this message
Reply

Tags
2004, bad, ball, car, fluid, input, joint, leaking, lower, rain, rear, struts, suggestions, tires

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Club4G Forum : Mitsubishi Eclipse 4G Forums - 2006-2012 Eclipse Authority forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
Real Name
What name do you go by?
Location
Where you live.
Type of Car
Year/Model/Trim
Insurance
Please select your insurance company (Optional)

Log-in



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Question: camber setup good or bad ? ked263 Wheels, Tires, Brakes and Suspension 2 November 2nd, 2015 01:14 PM
E brake makes bad noises. escapefate 2006-2012 Eclipse (General 4G) 6 July 31st, 2015 07:58 AM
Bad cats on a gt Austin269 4G Eclipse GT/SE Specific 5 July 27th, 2015 09:41 AM
Question: Sad face panda bear =( Possible bad engine SMeclipseGT 4G Eclipse GT/SE Specific 3 January 18th, 2015 06:42 PM
Painted Calipers? Good or bad? UVBlue1 Interior and Exterior Modifications (Show) 10 August 27th, 2014 04:45 PM


All times are GMT -5. The time now is 04:04 PM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Search Engine Friendly URLs by vBSEO
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
Ad Management plugin by RedTyger