I have a question Car locked up - Club4G Forum : Mitsubishi Eclipse 4G Forums - 2006-2012 Eclipse Authority
Support Our Troops!         
 

Go Back   Club4G Forum : Mitsubishi Eclipse 4G Forums - 2006-2012 Eclipse Authority > General > 2006-2012 Eclipse (General 4G)

2006-2012 Eclipse (General 4G) General discussion and information about the 2006-2012 (4th Generation) Eclipse.


Welcome to the Club4G Forums where you can join fellow owners from all over North America discussing anything related to the 2006+ Mitsubishi Eclipse. You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. To gain access to post topics, communicate privately with other members (PM), respond to polls, upload content, you must register today!

  • Participate in over 100 specialized forums!
  • Get event information regarding meets, mod days and help in our regionalized forums.
  • Gain access to our classified marketplace to buy, sell or trade parts.
  • Levarage a vast collection of Do-It-Yourself guides on steps on working on your Eclipse
  • Access to the growing online parts directory which gives you insight on available parts and the vendors that carry them.
  • Communicate privately with other owners.

All of this and much more is available to you absolutely free when you register for an account. Sign up today!

If you have any problems with the registration process or your account login, please contact contact us.
Reply
 
LinkBack Thread Tools Display Modes
Old June 21st, 2020, 10:15 AM   #1 (permalink)
Junior Member
 

Join Date: Jul 2018
Posts: 4
Rep Power: 3
ThomasH is on a distinguished road
Car locked up

Just wondering if anyone has any guesses on what could be going on with my car. I have a 08 2.4l auto eclipse. I was driving home from work at 1 am going 60 the car died suddenly, brakes locked up and transmission locked up in park, the car got towed to my place the engine won’t start. Any guesses on what could cause everything to lock up?
ThomasH is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old June 21st, 2020, 12:12 PM   #2 (permalink)
Senior Member
 

Name: Kyle
Join Date: Jan 2018
Location: Ohio
Vehicle: 2006 Eclipse GS Auto
Posts: 1,606
Rep Power: 4
pcfreak4 has a spectacular aura about
Mileage or kilometers on it? And when was its timing belt changed last?
pcfreak4 is online now   Reply With Quote Quick reply to this message
Old June 21st, 2020, 12:28 PM   #3 (permalink)
Junior Member
 

Join Date: Jul 2018
Posts: 4
Rep Power: 3
ThomasH is on a distinguished road
160,000 bought the car at 120,000 haven’t done the timing belt yet
ThomasH is offline   Reply With Quote Quick reply to this message
 
Old June 21st, 2020, 12:30 PM   #4 (permalink)
140whp+15.72%= 162hp
 
Sparda D'Mon's Avatar
 

Name: Richard.
Join Date: Dec 2018
Location: 162Hp - 13.58% = 140whp
Vehicle: 2007 Eclipse GS 2.4
Posts: 379
Rep Power: 2
Sparda D'Mon is on a distinguished road
Explain abit more. Do you have power when you turn the key? Does the engine turn but wont start?

Right now with your mileage is pointing to the timing belt... not a good thing. If the timing belt snapped while running good chance is you had piston and valves smooching causing valves to bend.

Last edited by Sparda D'Mon; June 21st, 2020 at 12:34 PM.
Sparda D'Mon is offline   Reply With Quote Quick reply to this message
Old June 21st, 2020, 01:09 PM   #5 (permalink)
Junior Member
 

Join Date: Jul 2018
Posts: 4
Rep Power: 3
ThomasH is on a distinguished road
Yeah i have power, the lights and all that turn on, it sounds like its trying turn over
ThomasH is offline   Reply With Quote Quick reply to this message
Old June 21st, 2020, 03:56 PM   #6 (permalink)
Senior Member
 

Name: Kyle
Join Date: Jan 2018
Location: Ohio
Vehicle: 2006 Eclipse GS Auto
Posts: 1,606
Rep Power: 4
pcfreak4 has a spectacular aura about
Quote:
Originally Posted by ThomasH View Post
Yeah i have power, the lights and all that turn on, it sounds like its trying turn over
I’m thinking your timing belt blew bud, sorry
Engine head needs rebuilt if that’s the case
This is an interference engine
pcfreak4 is online now   Reply With Quote Quick reply to this message
Old June 21st, 2020, 04:29 PM   #7 (permalink)
Basically Stock
 
Sabertooth^2's Avatar
Are you sure it was brakes that locked up, and that it's actually locked in park?

Timing belt wouldn't cause either of those. ABS module is the only thing that'll lock up brakes wrongly, and locked in park can't happen while moving as your parking pin would very easily shear
__________________
Photobucket p500 fix

My Build Thread


Find me at 4G World
Sabertooth^2 is online now   Reply With Quote Quick reply to this message
Old June 21st, 2020, 05:05 PM   #8 (permalink)
Senior Member
 

Name: Kyle
Join Date: Jan 2018
Location: Ohio
Vehicle: 2006 Eclipse GS Auto
Posts: 1,606
Rep Power: 4
pcfreak4 has a spectacular aura about
Quote:
Originally Posted by Sabertooth^2 View Post
Are you sure it was brakes that locked up, and that it's actually locked in park?

Timing belt wouldn't cause either of those. ABS module is the only thing that'll lock up brakes wrongly, and locked in park can't happen while moving as your parking pin would very easily shear
I’m thinking that he just lost boosted brakes because the engine died and then the car was stuck in drive which seemed like park? Idk need more info to help
pcfreak4 is online now   Reply With Quote Quick reply to this message
Old June 21st, 2020, 05:12 PM   #9 (permalink)
Junior Member
 

Join Date: Jul 2018
Posts: 4
Rep Power: 3
ThomasH is on a distinguished road
the car died going 60, i pulled to the side of the road, put it into park, and when i tried to start it again it wouldn't start, and the brakes and shifter were then locked
ThomasH is offline   Reply With Quote Quick reply to this message
Old June 21st, 2020, 08:47 PM   #10 (permalink)
Senior Member
 

Name: Kyle
Join Date: Jan 2018
Location: Ohio
Vehicle: 2006 Eclipse GS Auto
Posts: 1,606
Rep Power: 4
pcfreak4 has a spectacular aura about
Quote:
Originally Posted by ThomasH View Post
the car died going 60, i pulled to the side of the road, put it into park, and when i tried to start it again it wouldn't start, and the brakes and shifter were then locked
Any bad noises?
What happened on the tachometer? Sound of the engine? Power steering?
pcfreak4 is online now   Reply With Quote Quick reply to this message
Old June 21st, 2020, 10:48 PM   #11 (permalink)
Basically Stock
 
Sabertooth^2's Avatar
Ah, the brakes aren't locked then, and it just won't shift out of park.

That's a total different situation. So, when you crank the engine over, does it sound wrong, and seem to spin too fast?
__________________
Photobucket p500 fix

My Build Thread


Find me at 4G World
Sabertooth^2 is online now   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Club4G Forum : Mitsubishi Eclipse 4G Forums - 2006-2012 Eclipse Authority forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
Real Name
What name do you go by?
Location
Where you live.
Type of Car
Year/Model/Trim
Insurance
Please select your insurance company (Optional)

Log-in



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 07:49 PM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Search Engine Friendly URLs by vBSEO
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
Ad Management plugin by RedTyger