I have a question Troubleshooting ECOM in a Spyder - Club4G Forum : Mitsubishi Eclipse 4G Forums - 2006-2012 Eclipse Authority
Support Our Troops!         
 

Go Back   Club4G Forum : Mitsubishi Eclipse 4G Forums - 2006-2012 Eclipse Authority > Performance and Technical > Audio & Lighting

Audio & Lighting Head units, subs, amps, caps, neon lighting, LEDs, and anything else that uses a DC power source not tuning related goes here.


Welcome to the Club4G Forums where you can join fellow owners from all over North America discussing anything related to the 2006+ Mitsubishi Eclipse. You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. To gain access to post topics, communicate privately with other members (PM), respond to polls, upload content, you must register today!

  • Participate in over 100 specialized forums!
  • Get event information regarding meets, mod days and help in our regionalized forums.
  • Gain access to our classified marketplace to buy, sell or trade parts.
  • Levarage a vast collection of Do-It-Yourself guides on steps on working on your Eclipse
  • Access to the growing online parts directory which gives you insight on available parts and the vendors that carry them.
  • Communicate privately with other owners.

All of this and much more is available to you absolutely free when you register for an account. Sign up today!

If you have any problems with the registration process or your account login, please contact contact us.
Reply
 
LinkBack Thread Tools Display Modes
Old June 27th, 2020, 10:25 AM   #1 (permalink)
Junior Member
 
BlankWave's Avatar
 

Name: AJ
Join Date: May 2020
Location: Maryland
Vehicle: 09 Spyder GS
Posts: 19
Rep Power: 1
BlankWave is on a distinguished road
Troubleshooting ECOM in a Spyder

Hey guys. So I've soaked up what I can from past threads concerning ECOM and I have the following info to preface this troubleshooting with.

1. I have the stock Rockford Fosgate factory unit, though I have not visually confirmed the amp is stock.
2. I bought the car used and there does seem to be some evidence that an aftermarket unit may have been in the car at some point. There is a drilled hole in the back bumper, a perfect circle, off center and underneath where the license plate area is. My mechanic friend thinks they backed into something perfectly round, but the hole really does look perfectly drilled; even if that is not where most people would put a backup camera it seems worth noting. I was thinking one possible reason for the (hypothetical) silly rear camera placement might be the horrible rear visibility of the Spyder when you're backing out of a space? Additionally some of the the carpeting in the trunk is all loosey-goosey like somebody had to wire something.
3. The subwoofer seems like it is working to me. That bass is strong AF.

So here is where I'm at. I'm intermittently getting ECOM errors with the RF headunit. It comes and goes. I might think a wire was loose and is being knocked around while driving, but the ECOM also comes and goes sometimes while the car is parked.

I don't really care TOO much about it, except that I have a Spyder. That comes with an annoying bonus issue for us convertible owners. When ECOM resolves itself, if the top is in a different position than it was when the ECOM started, it beeps loudly to indicate the position of the top and then does a "sound adjust". Every time it happens it grinds on my nerves a little more, so it would be cool to solve it. If that's confusing, it would go like this:

Top is down. ECOM shows up.

2 Days later, Top is up and has been up all day. ECOM suddenly resolves and the display starts working, but it only just realizes the top is up so it beeps to let me know and then does the "sound adjust".

I die a little inside.


I have been behind the head unit when I installed my AUX cable and everything appeared snug. Since the subwoofer is also working, I'm thinking my problem could potentially be the wiring that communicates between the convertible top and the display. I have no clue how that wiring works. Perhaps something in the trunk area that is being jostled around by the things I have sliding around back there? Taking things out of the trunk might explain why ECOM sometimes resolves when the car hasn't moved, and that area is right behind the convertible top storage.

If anyone's got ideas, I'm all about them. Thanks!
__________________

2009 Mitsubishi Eclipse Spyder GS
Proud Member of the RAVE RED Gang.
Modifications: DC Sports CAI, Cool Sunglasses
BlankWave is online now   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old June 28th, 2020, 08:45 AM   #2 (permalink)
Junior Member
 
BlankWave's Avatar
 

Name: AJ
Join Date: May 2020
Location: Maryland
Vehicle: 09 Spyder GS
Posts: 19
Rep Power: 1
BlankWave is on a distinguished road
I figured a potential wiring issue with the convertible top might not get a lot of response. I'm going to poke around the storage area and trunk and see if I can spot a loose connection. If I find anything I'll leave it here for other unlucky Spyder owners.

I figure once I put a touchscreen headunit in, the main symptoms should stop since the ECOM error will be permanent.
__________________

2009 Mitsubishi Eclipse Spyder GS
Proud Member of the RAVE RED Gang.
Modifications: DC Sports CAI, Cool Sunglasses
BlankWave is online now   Reply With Quote Quick reply to this message
Reply

Tags
aftermarket, aux, back, bumper, car, display, fosgate, headunit, issue, king, license, owners, plate, problem, rear, rockford, rockford fosgate, sound, spyder, stock, subwoofer, top, uni, wire, works

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Club4G Forum : Mitsubishi Eclipse 4G Forums - 2006-2012 Eclipse Authority forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
Real Name
What name do you go by?
Location
Where you live.
Type of Car
Year/Model/Trim
Insurance
Please select your insurance company (Optional)

Log-in



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 10:30 AM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Search Engine Friendly URLs by vBSEO
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
Ad Management plugin by RedTyger