Transmission mount - Club4G Forum : Mitsubishi Eclipse 4G Forums - 2006-2012 Eclipse Authority
Support Our Troops!         
 

Go Back   Club4G Forum : Mitsubishi Eclipse 4G Forums - 2006-2012 Eclipse Authority > Performance and Technical > Driveline

Driveline Discussions about anything from the transmission to the axle nuts go here.


Welcome to the Club4G Forums where you can join fellow owners from all over North America discussing anything related to the 2006+ Mitsubishi Eclipse. You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. To gain access to post topics, communicate privately with other members (PM), respond to polls, upload content, you must register today!

  • Participate in over 100 specialized forums!
  • Get event information regarding meets, mod days and help in our regionalized forums.
  • Gain access to our classified marketplace to buy, sell or trade parts.
  • Levarage a vast collection of Do-It-Yourself guides on steps on working on your Eclipse
  • Access to the growing online parts directory which gives you insight on available parts and the vendors that carry them.
  • Communicate privately with other owners.

All of this and much more is available to you absolutely free when you register for an account. Sign up today!

If you have any problems with the registration process or your account login, please contact contact us.
Reply
 
LinkBack Thread Tools Display Modes
Old May 13th, 2017, 11:14 AM   #1 (permalink)
Junior Member
 
Jesse'seclipse's Avatar
 

Name: Jesse
Join Date: Feb 2017
Location: Colorado
Vehicle: 2006 eclipse gt
Posts: 11
Rep Power: 4
Jesse'seclipse is on a distinguished road
Transmission mount

Hi guys I have noticed on hard acceleration i hear a knocking sound coming from the driver side. Took me a while to figure it out but found the transmission mount is shot. I'm having trouble finding the right one for my car. It's a great with manual transmission. Can anyone? help me find where I can order one? Also will I need to loosen any of the other mounts to replace it? I appreciate any help I can get.
Jesse'seclipse is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old May 13th, 2017, 11:15 AM   #2 (permalink)
Junior Member
 
Jesse'seclipse's Avatar
 

Name: Jesse
Join Date: Feb 2017
Location: Colorado
Vehicle: 2006 eclipse gt
Posts: 11
Rep Power: 4
Jesse'seclipse is on a distinguished road
It's a GT not a great lol stupid auto correct.
Jesse'seclipse is offline   Reply With Quote Quick reply to this message
Old May 14th, 2017, 09:44 PM   #3 (permalink)
Junior Member
 
Jesse'seclipse's Avatar
 

Name: Jesse
Join Date: Feb 2017
Location: Colorado
Vehicle: 2006 eclipse gt
Posts: 11
Rep Power: 4
Jesse'seclipse is on a distinguished road
Also
Is there a polyurethane replacement mount for the transmission mount?
Jesse'seclipse is offline   Reply With Quote Quick reply to this message
 
Old May 13th, 2020, 07:32 AM   #4 (permalink)
Junior Member
 

Join Date: May 2020
Posts: 7
Rep Power: 1
slashfla is on a distinguished road
Im having the same issue with my 06 GT manual. I keep ordering trans mounts and they keep coming with a four bolt pattern but the one on the car has only a three bolt pattern. Cant find it anywhere! It's been this way with this car every step of the way. If you find a good sourcer for parts besides partsgeek and the regular parts houses it would be appreciated.
slashfla is offline   Reply With Quote Quick reply to this message
Old May 13th, 2020, 07:54 AM   #5 (permalink)
Senior Member
 

Name: Smokey
Join Date: Aug 2015
Location: Nc
Vehicle: 2007/Eclipse/gs
Posts: 355
Rep Power: 5
Smokeynbandit is on a distinguished road
Iíll ask my uncle where he got mine my ya trans mounts were gone he welded new mounts thatís all I know right now
Smokeynbandit is offline   Reply With Quote Quick reply to this message
Old May 13th, 2020, 11:49 AM   #6 (permalink)
Senior Member
 

Name: Smokey
Join Date: Aug 2015
Location: Nc
Vehicle: 2007/Eclipse/gs
Posts: 355
Rep Power: 5
Smokeynbandit is on a distinguished road
Well I figured out the mounts from the 07 eclipse and 09 trans I got didn’t match up he had to reweld mounts after buying the correct year for that trans. This is on a gs so probably not too helpful sorry
Smokeynbandit is offline   Reply With Quote Quick reply to this message
Old May 13th, 2020, 01:40 PM   #7 (permalink)
Basically Stock
 
Sabertooth^2's Avatar
I use an 06 trans mount on my 09. Your uncle got you the wrong part
__________________
Photobucket p500 fix

My Build Thread


Find me at 4G World
Sabertooth^2 is offline   Reply With Quote Quick reply to this message
Old May 13th, 2020, 05:58 PM   #8 (permalink)
Senior Member
 

Name: Smokey
Join Date: Aug 2015
Location: Nc
Vehicle: 2007/Eclipse/gs
Posts: 355
Rep Power: 5
Smokeynbandit is on a distinguished road
Haha yea idk what parts he got that’s all he said when I asked I bought the transmission online off eBay for $200 with 80k miles, altogether we had $1000 into everything but he also towed it for over a hr away so I didn’t mind giving the extra,he didn’t actually charge for the tow, and he paid a driver to come get it and take it to back the shop another hr away. if I knew I could lift the trans and put it in myself I woulda but I didn’t know enough about it. He bought new gaskets ect so I figure he had maybe 1-$200 at most plus the labor of shop time for his employees. To some it might seem high but they’ll also look at it for free anytime for any issues not only the trans. We just don’t expect anything from anyone for free lol cause if we selling something we want close to what we want too lol
Smokeynbandit is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Club4G Forum : Mitsubishi Eclipse 4G Forums - 2006-2012 Eclipse Authority forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
Real Name
What name do you go by?
Location
Where you live.
Type of Car
Year/Model/Trim
Insurance
Please select your insurance company (Optional)

Log-in



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Clutch and Transmission Noise Ohioguy Problem Reports 10 January 4th, 2017 11:14 AM
Six Speed Manual Transmission Rebuild Issue Timmy42 Problem Reports 4 April 10th, 2016 06:33 PM
Question: Transaxle mount?? Inali 2006-2012 Eclipse (General 4G) 5 February 15th, 2016 06:11 PM
Checking Transmission Fluid? Silence_ 2006-2012 Eclipse (General 4G) 3 September 10th, 2015 04:07 PM
Ghetto Upper Tranmission mount install. inherheart Problem Reports 1 August 7th, 2015 12:59 AM


All times are GMT -5. The time now is 07:11 AM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Search Engine Friendly URLs by vBSEO
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
Ad Management plugin by RedTyger