Club4G Forum : Mitsubishi Eclipse 4G Forums - 2006-2012 Eclipse Authority - Reply to Topic
Support Our Troops!         
 

Go Back   Club4G Forum : Mitsubishi Eclipse 4G Forums - 2006-2012 Eclipse Authority > General > 2006-2012 Eclipse (General 4G) > I have a question 2007 4G GT blows Engine control 20Amp fuse

2006-2012 Eclipse (General 4G) General discussion and information about the 2006-2012 (4th Generation) Eclipse.


Welcome to the Club4G Forums where you can join fellow owners from all over North America discussing anything related to the 2006+ Mitsubishi Eclipse. You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. To gain access to post topics, communicate privately with other members (PM), respond to polls, upload content, you must register today!

  • Participate in over 100 specialized forums!
  • Get event information regarding meets, mod days and help in our regionalized forums.
  • Gain access to our classified marketplace to buy, sell or trade parts.
  • Levarage a vast collection of Do-It-Yourself guides on steps on working on your Eclipse
  • Access to the growing online parts directory which gives you insight on available parts and the vendors that carry them.
  • Communicate privately with other owners.

All of this and much more is available to you absolutely free when you register for an account. Sign up today!

If you have any problems with the registration process or your account login, please contact contact us.
Thread: I have a question 2007 4G GT blows Engine control 20Amp fuse Reply to Thread
Title:
  
Message:
Trackback
Send Trackbacks to (Separate multiple URLs with spaces):
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Club4G Forum : Mitsubishi Eclipse 4G Forums - 2006-2012 Eclipse Authority forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
Real Name
What name do you go by?
Location
Where you live.
Type of Car
Year/Model/Trim
Insurance
Please select your insurance company (Optional)

Log-in


Additional Options
Miscellaneous Options

Topic Review (Newest First)
July 31st, 2020 11:21 PM
pcfreak4
Quote:
Originally Posted by alex_sauvage View Post
An update: hopefully it will be helpful to someone. 20Amp fuse # 9 goes to majority of engine sensors. I started checking sensor wiring and noticed that heat shield is touching oxygen sensor wire. Could not see any damage to the wire, but after I eliminated the contact things went back to normal. Been driving for a week now and no blown fuses. I guess somehow the circuit was grounding as I was driving and it would blow the fuse. Interesting, the engine would not stall, even when most sensors were disabled by blown fuse. But I could feel some loss of power, but not much. Hopefully things will stay OK.
Thanks for the update, yeah if any sensor goes offline, the ECU has preset failsafes programmed in to keep running anyway, aside from the crankshaft and camshaft sensors, and probably the knock sensor at the minimum for it to at least run
July 31st, 2020 12:32 PM
alex_sauvage An update: hopefully it will be helpful to someone. 20Amp fuse # 9 goes to majority of engine sensors. I started checking sensor wiring and noticed that heat shield is touching oxygen sensor wire. Could not see any damage to the wire, but after I eliminated the contact things went back to normal. Been driving for a week now and no blown fuses. I guess somehow the circuit was grounding as I was driving and it would blow the fuse. Interesting, the engine would not stall, even when most sensors were disabled by blown fuse. But I could feel some loss of power, but not much. Hopefully things will stay OK.
July 11th, 2020 04:48 PM
pcfreak4
Quote:
Originally Posted by alex_sauvage View Post
Tried it today with cold engine: everything seems fine. Was able to check codes: none, obviously. Any idea what part/connection could be so sensetive to heat? Also sorry for stupid question: what Front ECU relay does (black box within fuse box, not main ECU)? Could that be a problem? It was pretty hot yesterday.
It gets hot, that’s normal, even a warning sticker on it about that

I believe it works with the ETACS module to control the lights and things like that

Don’t believe anybody has ever reported a problem with one

Mitsubishi makes good electronics
July 11th, 2020 04:17 PM
alex_sauvage Tried it today with cold engine: everything seems fine. Was able to check codes: none, obviously. Any idea what part/connection could be so sensetive to heat? Also sorry for stupid question: what Front ECU relay does (black box within fuse box, not main ECU)? Could that be a problem? It was pretty hot yesterday.
July 10th, 2020 08:34 PM
pcfreak4 Hmm idk man, never heard of this issue, not a common problem for these cars to ever blow fuses at all unless some modification or repair was done improperly
July 10th, 2020 02:13 PM
alex_sauvage
2007 4G GT blows Engine control 20Amp fuse

Mine 2007 4G GT started to blow Engine control 20Amp fuse (#9). Happens on start up: just turning ighnition ON, without cranking an engine blows the fuse. Cannot even pull the code. Front ECU (one in fuse box) feels pretty hot, but then again it is 95F outside . Any suggestion guys?

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On


All times are GMT -5. The time now is 09:14 PM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Search Engine Friendly URLs by vBSEO
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
Ad Management plugin by RedTyger