Suspension noise after Megan Racing Lowering Spring Install - Club4G Forum : Mitsubishi Eclipse 4G Forums - 2006-2012 Eclipse Authority
Support Our Troops!         
 

Go Back   Club4G Forum : Mitsubishi Eclipse 4G Forums - 2006-2012 Eclipse Authority > General > Problem Reports

Problem Reports If you have a problem with your Eclipse you need assistance with, this is the forum to post your question and get answers.


Welcome to the Club4G Forums where you can join fellow owners from all over North America discussing anything related to the 2006+ Mitsubishi Eclipse. You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. To gain access to post topics, communicate privately with other members (PM), respond to polls, upload content, you must register today!

  • Participate in over 100 specialized forums!
  • Get event information regarding meets, mod days and help in our regionalized forums.
  • Gain access to our classified marketplace to buy, sell or trade parts.
  • Levarage a vast collection of Do-It-Yourself guides on steps on working on your Eclipse
  • Access to the growing online parts directory which gives you insight on available parts and the vendors that carry them.
  • Communicate privately with other owners.

All of this and much more is available to you absolutely free when you register for an account. Sign up today!

If you have any problems with the registration process or your account login, please contact contact us.
Reply
 
LinkBack Thread Tools Display Modes
Old September 30th, 2019, 01:15 AM   #1 (permalink)
Junior Member
 

Join Date: Sep 2019
Posts: 8
Rep Power: 2
IgNoctua is on a distinguished road
Suspension noise after Megan Racing Lowering Spring Install

Roughly two weeks ago I lowered my '06 GT on Megan Racing Lowering Springs, mostly in the interest of just getting rid of factory wheel gap, and to lower the car but not far enough to completely slam it. I probably won't be racing the car but I do care for my car to have good performance on top of good looks, however I couldn't justify spending $1000 on coil-overs just to rid wheel gap.

I did the install myself, and then I took the car to get full alignment to fix whatever accidental camber problems I caused from the new suspension pressure, they quickly checked behind me at the shop and said I did a very good job on the install (I'm pretty new to doing mechanic work but I wanted to do it myself just for the satisfaction of learning how, and of course it saved me a good $200).

However, ever since I installed them I've had a bit of a knocking or clacking type noise whenever the suspension is forced upwards from the ground, like going over a speed bump for example. Going over like a small pothole that is lower than the car is doesn't make the noise, but if it goes over a raised bump it sounds like it's knocking. And this is at any speed. So it seems like whenever the springs compress even more than they sit is when it happens.

I'm not exactly sure whether this is an actual problem or not. I've had a friend who used to mod and race his car (not an Eclipse, he had a 3000Gt when he raced) and knew other people that did tell me that sometimes aftermarket suspensions on such an old frame just make noise and it's not really anything to worry about. I'm just on here making sure that that is the case and that I'm not going to destroy anything on my car driving these lowering springs. The noise is annoying and it does seem a little janky but I'm not super bothered with it as long as it isn't damaging my car.

I've heard that sometimes the struts may not be able to handle the pressure of lowering springs, and that I may need new struts. But I don't want to spend out and buy new struts and then take the 4+ hours to put them on, and it not really do anything. Honestly the lowering springs were almost a temporary fix. If I get to build out the car how I like I'd probably switch to coils later down the road, it was just I could lower the car and drop my center of gravity for $200 as opposed to $1000 as my first ever car mod. I just don't want to seriously damage anything in the meantime.
IgNoctua is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old October 1st, 2019, 10:15 AM   #2 (permalink)
Senior Member
 

Name: Kevin
Join Date: Apr 2015
Location: Tampa
Vehicle: 2018 Golf R/2002 Ranger
Posts: 154
Rep Power: 6
#TampaEclipse is on a distinguished road
No, it shouldn't be doing that. If you installed those springs and your suspension started making noise after, then either the spring is not installed correctly, or some other suspension component has failed, and this failure either did not manifest itself at the stock ride height, or occurred because the replaced springs knocked something else out of tolerance.

I would *highly* recommend you attempt to identify it's cause before returning to your mechanic. Figure out which wheel the noise is coming from, then take it off and just look around for anything that looks wrong; worn, torn or damaged components as well as movement tolerances. The best way to make sure a mechanic doesn't cover his own faulty repair is to take it back and just say it's broken. Have an idea why and explain how it could have come to be this way while in their care.
#TampaEclipse is online now   Reply With Quote Quick reply to this message
Old October 1st, 2019, 05:04 PM   #3 (permalink)
Junior Member
 

Join Date: Sep 2019
Posts: 8
Rep Power: 2
IgNoctua is on a distinguished road
I'm pretty confident they are installed correctly I made sure everything was lined up and I even tightened them after putting them on. The Megans didn't seem to fit exactly perfectly in the first place it's a slight bit off from how the stock springs used to sit which is why I wasn't sure if they just do that. It also looks like there's just not much clearance between my tire and the bottom of the lower spring pad/insulator and I thought maybe they might be knocking together sometimes.

I'd expect that something else is probably wrong if those are the two options, and I wouldn't be that surprised if the extra stress from the lowering springs just highlighted another existing problem. I will probably have a hard time determining what though as I don't have much experience.
IgNoctua is offline   Reply With Quote Quick reply to this message
 
Old October 2nd, 2019, 11:47 AM   #4 (permalink)
Junior Member
 
ItsMIVECyo's Avatar
 

Join Date: Oct 2019
Location: Jacksonville, Florida
Vehicle: 2007 Eclipse SE
Posts: 3
Rep Power: 2
ItsMIVECyo is on a distinguished road
Just my two cents here. I don't really think something is really wrong. I am pretty sure if they were not installed correctly, you would definitely be having a drivability problem. Car would get unsettled, abnormal steering over bumps, etc. First thing I would do is to see if you notice the noise coming from the left, right, front, or rear. That's usually an indication that it is centralized problem and will definitely narrow your search down. Did you notice the noise immediately after or gradually after the fact? When I was on my Tein lowering springs, the car got clunkier over bumps just from the extra stress of those springs but it was nothing wrong. Although after a while, I did notice a clunking that was more noticeable from the driver side rear. Turns out I had knuckle bushings on the control arm totally busted up. This might already be something happening to you depending on the age of your car even before the springs. If you've got a strut going bad, you can turn your front wheels to see if you see any liquid dripping down the assembly, that is the sign that you've got a bad one, no need to take them off (this might be a good idea anyway to check, as I thought one of my struts was going, so I checked and I actually had a CV axle spraying grease all over the place!!) Another sign something is wrong is that after driving for a while, if your alignment is back off even though you hadn't hit any huge bumps or something over and over, there is a suspension problem happening. I would start with that stuff and go from there
ItsMIVECyo is offline   Reply With Quote Quick reply to this message
Old October 2nd, 2019, 11:57 AM   #5 (permalink)
Junior Member
 
ItsMIVECyo's Avatar
 

Join Date: Oct 2019
Location: Jacksonville, Florida
Vehicle: 2007 Eclipse SE
Posts: 3
Rep Power: 2
ItsMIVECyo is on a distinguished road
One thing I forgot to mention, I know for my S-Tech springs, you had to cut the factory bump stop some specified amount depending on the drop before install. Is anything like that mentioned for the Megan install? That may also be your problem!
ItsMIVECyo is offline   Reply With Quote Quick reply to this message
Old October 3rd, 2019, 12:26 PM   #6 (permalink)
Junior Member
 

Join Date: Sep 2019
Posts: 8
Rep Power: 2
IgNoctua is on a distinguished road
Yeah I did cut the bumps but I didn't know there was supposed to be a specified amount I just cut off one link. The noise is from the front, both sides. The back is completely quiet. It was immediately after I put the springs on. My friends said "oh yeah just wait for them to settle in they might move slightly for awhile". So I just wrote it off for the first bit. And I haven't seen any leaking, I park on a curb at work and always turn my wheels all the way there hasn't been any leaking I've noticed. I guess I'll wait to see if my alignment goes back off it seems pretty fine right now. I even pulled my wheels back off and made sure everything was tightened and couldn't find anything even remotely loose
IgNoctua is offline   Reply With Quote Quick reply to this message
Reply

Tags
06 gt, aftermarket, buy, car, eclipse, fix, good, handle, install, lowering, lowering springs, mod, noise, performance, problems, race, racing, shop, springs, struts, super, suspension, top, wheel, work

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Club4G Forum : Mitsubishi Eclipse 4G Forums - 2006-2012 Eclipse Authority forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
Real Name
What name do you go by?
Location
Where you live.
Type of Car
Year/Model/Trim
Insurance
Please select your insurance company (Optional)

Log-in



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 04:57 PM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Search Engine Friendly URLs by vBSEO
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
Ad Management plugin by RedTyger