TCS Off light - Club4G Forum : Mitsubishi Eclipse 4G Forums - 2006-2012 Eclipse Authority
Support Our Troops!         
 

Go Back   Club4G Forum : Mitsubishi Eclipse 4G Forums - 2006-2012 Eclipse Authority > General > Problem Reports

Problem Reports If you have a problem with your Eclipse you need assistance with, this is the forum to post your question and get answers.


Welcome to the Club4G Forums where you can join fellow owners from all over North America discussing anything related to the 2006+ Mitsubishi Eclipse. You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. To gain access to post topics, communicate privately with other members (PM), respond to polls, upload content, you must register today!

  • Participate in over 100 specialized forums!
  • Get event information regarding meets, mod days and help in our regionalized forums.
  • Gain access to our classified marketplace to buy, sell or trade parts.
  • Levarage a vast collection of Do-It-Yourself guides on steps on working on your Eclipse
  • Access to the growing online parts directory which gives you insight on available parts and the vendors that carry them.
  • Communicate privately with other owners.

All of this and much more is available to you absolutely free when you register for an account. Sign up today!

If you have any problems with the registration process or your account login, please contact contact us.
Reply
 
LinkBack Thread Tools Display Modes
Old April 27th, 2020, 05:37 PM   #1 (permalink)
Member
 

Name: Person
Join Date: Aug 2016
Location: Illinois
Vehicle: 2008 Eclipse GT
Posts: 36
Rep Power: 4
KuzuRyuSen is on a distinguished road
TCS Off light

Hi,
I started up my car today and the TCS Off light was on, and won't respond to the button to turn it back on. What would cause this?
KuzuRyuSen is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old April 28th, 2020, 10:25 AM   #2 (permalink)
Senior Member
 

Name: Kyle
Join Date: Jan 2018
Location: Ohio
Vehicle: 2006 Eclipse GS Auto
Posts: 1,608
Rep Power: 4
pcfreak4 has a spectacular aura about
Push the button

Got a check engine light? A code can turn off the TC system too
pcfreak4 is offline   Reply With Quote Quick reply to this message
Old April 28th, 2020, 12:24 PM   #3 (permalink)
Basically Stock
 
Sabertooth^2's Avatar
Usually caused by issues related to the air intake, wheel speed sensors, or as you have a GT, the brake lights


A good scan tool will show you which module is triggering it, even if there's no check engine light.
__________________
Photobucket p500 fix

My Build Thread


Find me at 4G World
Sabertooth^2 is offline   Reply With Quote Quick reply to this message
 
Old May 4th, 2020, 12:48 PM   #4 (permalink)
Member
 

Name: Person
Join Date: Aug 2016
Location: Illinois
Vehicle: 2008 Eclipse GT
Posts: 36
Rep Power: 4
KuzuRyuSen is on a distinguished road
The brake lights? Wow. Thanks, wouldn't have thought of that. There is a separate SES light that's been going on and off for a cat converter fail, maybe one is buried underneath that. I'm so used to ignoring it that I didn't think to check there
KuzuRyuSen is offline   Reply With Quote Quick reply to this message
Old May 4th, 2020, 12:57 PM   #5 (permalink)
140whp+15.72%= 162hp
 
Sparda D'Mon's Avatar
 

Name: Richard.
Join Date: Dec 2018
Location: 162Hp - 13.58% = 140whp
Vehicle: 2007 Eclipse GS 2.4
Posts: 379
Rep Power: 2
Sparda D'Mon is on a distinguished road
GS have TC or just GT?
Sparda D'Mon is offline   Reply With Quote Quick reply to this message
Old May 4th, 2020, 03:01 PM   #6 (permalink)
Senior Member
 

Name: Kyle
Join Date: Jan 2018
Location: Ohio
Vehicle: 2006 Eclipse GS Auto
Posts: 1,608
Rep Power: 4
pcfreak4 has a spectacular aura about
Quote:
Originally Posted by KuzuRyuSen View Post
The brake lights? Wow. Thanks, wouldn't have thought of that. There is a separate SES light that's been going on and off for a cat converter fail, maybe one is buried underneath that. I'm so used to ignoring it that I didn't think to check there :-)
Brake light issues will usually cause cruise control issues as the cruise control looks at the brake lights to see if they come on to cancel cruise control
Although everything is connected so ABS and TC issues could be related too
pcfreak4 is offline   Reply With Quote Quick reply to this message
Old May 4th, 2020, 03:01 PM   #7 (permalink)
Senior Member
 

Name: Kyle
Join Date: Jan 2018
Location: Ohio
Vehicle: 2006 Eclipse GS Auto
Posts: 1,608
Rep Power: 4
pcfreak4 has a spectacular aura about
Quote:
Originally Posted by Sparda D'Mon View Post
GS have TC or just GT?
My GS doesn’t but I think some GS do have it
pcfreak4 is offline   Reply With Quote Quick reply to this message
Old May 4th, 2020, 03:21 PM   #8 (permalink)
Basically Stock
 
Sabertooth^2's Avatar
Correct. Some GS do. I think just the automatics though. Some have it, and can't disable it either unless they install the button
__________________
Photobucket p500 fix

My Build Thread


Find me at 4G World
Sabertooth^2 is offline   Reply With Quote Quick reply to this message
Old May 4th, 2020, 08:18 PM   #9 (permalink)
Senior Member
 

Name: Kyle
Join Date: Jan 2018
Location: Ohio
Vehicle: 2006 Eclipse GS Auto
Posts: 1,608
Rep Power: 4
pcfreak4 has a spectacular aura about
Mine doesn’t have it at all, it is an 06 GS auto base model tho so that’s prob why
pcfreak4 is offline   Reply With Quote Quick reply to this message
Old May 4th, 2020, 08:37 PM   #10 (permalink)
Basically Stock
 
Sabertooth^2's Avatar
Funny enough, I have the button, but it does nothing. I snagged it from a GS in the junkyard for the fog light switch, which I'm not sure what to do with now that I'm turning my fog light bezels into brake cooling ducts
__________________
Photobucket p500 fix

My Build Thread


Find me at 4G World
Sabertooth^2 is offline   Reply With Quote Quick reply to this message
Old May 4th, 2020, 09:06 PM   #11 (permalink)
Senior Member
 

Name: Kyle
Join Date: Jan 2018
Location: Ohio
Vehicle: 2006 Eclipse GS Auto
Posts: 1,608
Rep Power: 4
pcfreak4 has a spectacular aura about
Quote:
Originally Posted by Sabertooth^2 View Post
Funny enough, I have the button, but it does nothing. I snagged it from a GS in the junkyard for the fog light switch, which I'm not sure what to do with now that I'm turning my fog light bezels into brake cooling ducts
What if u turn it on in fastworks? U have a manual tho
pcfreak4 is offline   Reply With Quote Quick reply to this message
Old May 4th, 2020, 09:14 PM   #12 (permalink)
Basically Stock
 
Sabertooth^2's Avatar
It's not programmed for a manual GS, so it does nothing.

Michael is working on the V6 manual TC right now though, tweaking it. I'm honestly not sure what he's adjusting for it, but I'd guess he's trying to make it more track friendly.
__________________
Photobucket p500 fix

My Build Thread


Find me at 4G World
Sabertooth^2 is offline   Reply With Quote Quick reply to this message
Old May 4th, 2020, 11:12 PM   #13 (permalink)
Senior Member
 

Name: Kyle
Join Date: Jan 2018
Location: Ohio
Vehicle: 2006 Eclipse GS Auto
Posts: 1,608
Rep Power: 4
pcfreak4 has a spectacular aura about
Do u know if on my 06 GS auto, if enabling TC in the tune and getting the button would make it work?
Or is there something different about the ABS module, wheel speed sensors or something?
pcfreak4 is offline   Reply With Quote Quick reply to this message
Old May 5th, 2020, 09:45 AM   #14 (permalink)
140whp+15.72%= 162hp
 
Sparda D'Mon's Avatar
 

Name: Richard.
Join Date: Dec 2018
Location: 162Hp - 13.58% = 140whp
Vehicle: 2007 Eclipse GS 2.4
Posts: 379
Rep Power: 2
Sparda D'Mon is on a distinguished road
Funny you mention cooling duct. I was planning on removing the driver side plastic cover for the fog light to allow air to flow in since my CAI sits right behind it. Good idea or what you think?
Sparda D'Mon is offline   Reply With Quote Quick reply to this message
Old May 5th, 2020, 10:02 AM   #15 (permalink)
Basically Stock
 
Sabertooth^2's Avatar
I'm not sure if your ECU has the software in it by default. You can always give it a try though

As for the CAI intake, not really. I don't think you'll notice any gains. I'm also not just opening mine up, but running a duct right to the lowest pressure area of the rotor that I can. If you ran your intake with a bell mouth opening to the front of the car in the same style, you may see gains. But you'd also see bugs, dirt, rocks, rain, etc.
__________________
Photobucket p500 fix

My Build Thread


Find me at 4G World
Sabertooth^2 is offline   Reply With Quote Quick reply to this message
Old May 5th, 2020, 01:45 PM   #16 (permalink)
Senior Member
 

Name: Kyle
Join Date: Jan 2018
Location: Ohio
Vehicle: 2006 Eclipse GS Auto
Posts: 1,608
Rep Power: 4
pcfreak4 has a spectacular aura about
Quote:
Originally Posted by Sabertooth^2 View Post
I'm not sure if your ECU has the software in it by default. You can always give it a try though

As for the CAI intake, not really. I don't think you'll notice any gains. I'm also not just opening mine up, but running a duct right to the lowest pressure area of the rotor that I can. If you ran your intake with a bell mouth opening to the front of the car in the same style, you may see gains. But you'd also see bugs, dirt, rocks, rain, etc.
I have the option in fastworks but I don’t have the button tho
pcfreak4 is offline   Reply With Quote Quick reply to this message
Old May 5th, 2020, 11:07 PM   #17 (permalink)
140whp+15.72%= 162hp
 
Sparda D'Mon's Avatar
 

Name: Richard.
Join Date: Dec 2018
Location: 162Hp - 13.58% = 140whp
Vehicle: 2007 Eclipse GS 2.4
Posts: 379
Rep Power: 2
Sparda D'Mon is on a distinguished road
Got it. I think i'll buy a new bumper. Mine is broken on the passenger side. Has a white spot as if previous owner hit a white wall by accident or a white post. Also fender guard is broken. Maybe a blown tire?
Sparda D'Mon is offline   Reply With Quote Quick reply to this message
Old May 11th, 2020, 12:12 AM   #18 (permalink)
Member
 

Name: Person
Join Date: Aug 2016
Location: Illinois
Vehicle: 2008 Eclipse GT
Posts: 36
Rep Power: 4
KuzuRyuSen is on a distinguished road
Quote:
Originally Posted by Sparda D'Mon View Post
Got it. I think i'll buy a new bumper. Mine is broken on the passenger side. Has a white spot as if previous owner hit a white wall by accident or a white post. Also fender guard is broken. Maybe a blown tire?
Impact may have broken the fender guard but only flexed the bumper?
KuzuRyuSen is offline   Reply With Quote Quick reply to this message
Old May 12th, 2020, 10:35 AM   #19 (permalink)
140whp+15.72%= 162hp
 
Sparda D'Mon's Avatar
 

Name: Richard.
Join Date: Dec 2018
Location: 162Hp - 13.58% = 140whp
Vehicle: 2007 Eclipse GS 2.4
Posts: 379
Rep Power: 2
Sparda D'Mon is on a distinguished road
Who knows. Like i said ill look for a new bumper. Found them somewhere for like 80-90$
Sparda D'Mon is offline   Reply With Quote Quick reply to this message
Old May 12th, 2020, 10:57 AM   #20 (permalink)
Senior Member
 

Name: Kyle
Join Date: Jan 2018
Location: Ohio
Vehicle: 2006 Eclipse GS Auto
Posts: 1,608
Rep Power: 4
pcfreak4 has a spectacular aura about
Quote:
Originally Posted by Sparda D'Mon View Post
Funny you mention cooling duct. I was planning on removing the driver side plastic cover for the fog light to allow air to flow in since my CAI sits right behind it. Good idea or what you think?
Not really, I tried it and I think it was just a placebo thing, it’ll get debris stuck to it way easier too
pcfreak4 is offline   Reply With Quote Quick reply to this message
Reply

Tags
back, button, car, light

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Club4G Forum : Mitsubishi Eclipse 4G Forums - 2006-2012 Eclipse Authority forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
Real Name
What name do you go by?
Location
Where you live.
Type of Car
Year/Model/Trim
Insurance
Please select your insurance company (Optional)

Log-in



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 11:43 PM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Search Engine Friendly URLs by vBSEO
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
Ad Management plugin by RedTyger