Airbag Light on After Removing and Reinstalling seats. - Club4G Forum : Mitsubishi Eclipse 4G Forums - 2006-2012 Eclipse Authority
Support Our Troops!         
 

Go Back   Club4G Forum : Mitsubishi Eclipse 4G Forums - 2006-2012 Eclipse Authority > General > Problem Reports

Problem Reports If you have a problem with your Eclipse you need assistance with, this is the forum to post your question and get answers.


Welcome to the Club4G Forums where you can join fellow owners from all over North America discussing anything related to the 2006+ Mitsubishi Eclipse. You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. To gain access to post topics, communicate privately with other members (PM), respond to polls, upload content, you must register today!

  • Participate in over 100 specialized forums!
  • Get event information regarding meets, mod days and help in our regionalized forums.
  • Gain access to our classified marketplace to buy, sell or trade parts.
  • Levarage a vast collection of Do-It-Yourself guides on steps on working on your Eclipse
  • Access to the growing online parts directory which gives you insight on available parts and the vendors that carry them.
  • Communicate privately with other owners.

All of this and much more is available to you absolutely free when you register for an account. Sign up today!

If you have any problems with the registration process or your account login, please contact contact us.
Reply
 
LinkBack Thread Tools Display Modes
Old April 28th, 2020, 11:13 AM   #1 (permalink)
Member
 
Walketfretts's Avatar
 

Join Date: Mar 2020
Posts: 39
Rep Power: 1
Walketfretts is on a distinguished road
Airbag Light on After Removing and Reinstalling seats.

I took the liberty during today's nice weather to detail my car. Everything went smoothly, everything is connected up properly to the best of of my knowledge. The only problem is that the airbag light is on now. Could this be a problem with the plugs under the seat? I did a ECU reset to see if that did something but zip. I don't have a diagnostic reader so if you could just spare me that and just give me some basic ideas as to what I could do to fix it without clearing the code with a scanner? Or do I seriously need a scanner to clear the light? This is my first car so forgive my ignorance haha.
Walketfretts is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old April 28th, 2020, 11:47 AM   #2 (permalink)
Gamer
 
cmturner's Avatar
 

Name: Colten
Join Date: Dec 2012
Location: Houston TX
Vehicle: 2007/Eclipse GS 5 Speed
Posts: 6,863
Rep Power: 14
cmturner is a splendid one to beholdcmturner is a splendid one to beholdcmturner is a splendid one to beholdcmturner is a splendid one to beholdcmturner is a splendid one to beholdcmturner is a splendid one to behold
You didn't disconnect the battery before removing seats, you have to take it to the dealership or order a hundred dollar programmer to turn it off,
A few threads on which programmer it is, just use the search button
__________________
Try and take my guns, I DARE you!!!!
https://club4g.org/board/members-ride...ners-ride.html
cmturner is offline   Reply With Quote Quick reply to this message
Old April 28th, 2020, 11:54 AM   #3 (permalink)
Member
 
Walketfretts's Avatar
 

Join Date: Mar 2020
Posts: 39
Rep Power: 1
Walketfretts is on a distinguished road
Quote:
Originally Posted by cmturner View Post
You didn't disconnect the battery before removing seats, you have to take it to the dealership or order a hundred dollar programmer to turn it off,
A few threads on which programmer it is, just use the search button
Thanks man. This is the second time iv done something like this without disconnecting the battery. I even did a coolant bypass without disconnecting it. Its sucks being a dumbass sometimes haha
Walketfretts is offline   Reply With Quote Quick reply to this message
 
Old April 28th, 2020, 12:02 PM   #4 (permalink)
Senior Member
 

Name: Kyle
Join Date: Jan 2018
Location: Ohio
Vehicle: 2006 Eclipse GS Auto
Posts: 1,608
Rep Power: 4
pcfreak4 has a spectacular aura about
Do not mess with airbag wiring or systems with the battery connected! You could set one off and seriously injure yourself

Anyway, yes the issue is probably that you moved the seats forward and backwards and the system saw varying resistances because when the seats go all the way back the wires start to stretch a little

My passenger seat set off the light and my scan tool told me it was the passenger seat after we slid it all the way forward and back to load people and stuff into the backseat

I disconnected the battery, wait 10 minutes, touch battery leads together, turn key to drain power, unplugged the plugs Under the seat and the spring actually flew out of the plug and I had to go find it and put the plug back together, reconnected the plugs, light still on so reset it and it was fine ever since

I try to avoid unnecessarily moving the seats forward and back to avoid this

But yes now that you’ve set an SRS code, it will not go away no matter what you do, fix it, unplug battery, until you actually get a scan tool to reset it

Autel AL619 or DiagLink or MD802/MD808 can all do SRS

The AL619 only does 4 modules the others do all, I recommend one that can do all, I have the AL619 and stepped up to the DiagLink
pcfreak4 is online now   Reply With Quote Quick reply to this message
Old April 28th, 2020, 12:05 PM   #5 (permalink)
Senior Member
 

Name: Kyle
Join Date: Jan 2018
Location: Ohio
Vehicle: 2006 Eclipse GS Auto
Posts: 1,608
Rep Power: 4
pcfreak4 has a spectacular aura about
Also, big tip, never try to probe the prongs of an airbag (such as seat side plugs, airbag side only) with a multimeter (to try and check resistance) or anything metal, it will go off
pcfreak4 is online now   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Club4G Forum : Mitsubishi Eclipse 4G Forums - 2006-2012 Eclipse Authority forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
Real Name
What name do you go by?
Location
Where you live.
Type of Car
Year/Model/Trim
Insurance
Please select your insurance company (Optional)

Log-in



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 10:17 PM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Search Engine Friendly URLs by vBSEO
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
Ad Management plugin by RedTyger