Ecu was fried and replaced but still having issues - Club4G Forum : Mitsubishi Eclipse 4G Forums - 2006-2012 Eclipse Authority
Support Our Troops!         
 

Go Back   Club4G Forum : Mitsubishi Eclipse 4G Forums - 2006-2012 Eclipse Authority > General > Problem Reports

Problem Reports If you have a problem with your Eclipse you need assistance with, this is the forum to post your question and get answers.


Welcome to the Club4G Forums where you can join fellow owners from all over North America discussing anything related to the 2006+ Mitsubishi Eclipse. You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. To gain access to post topics, communicate privately with other members (PM), respond to polls, upload content, you must register today!

  • Participate in over 100 specialized forums!
  • Get event information regarding meets, mod days and help in our regionalized forums.
  • Gain access to our classified marketplace to buy, sell or trade parts.
  • Levarage a vast collection of Do-It-Yourself guides on steps on working on your Eclipse
  • Access to the growing online parts directory which gives you insight on available parts and the vendors that carry them.
  • Communicate privately with other owners.

All of this and much more is available to you absolutely free when you register for an account. Sign up today!

If you have any problems with the registration process or your account login, please contact contact us.
Reply
 
LinkBack Thread Tools Display Modes
Old May 29th, 2020, 09:42 PM   #1 (permalink)
Junior Member
 

Join Date: May 2020
Posts: 2
Rep Power: 1
Casteelo is on a distinguished road
Ecu was fried and replaced but still having issues

I have an 07 eclipse gt, the car died on the highway and after i checked there was no oil in the engine. The car flashed all lights when it died. I replaced the ecu, coils, and gutted the 3rd cat since it was clogged. The car now runs but has some issues, it feels a little rough to drive but still powerful. I have the TCL on, along with the oil light but it has oil, the CEL is on too but its only for the o2 sensor. The windows dont roll down automatically and the passenger door wont unlock, it all used to work perfectly fine but idk what happened, any thoughts?
Thank you guys in advance
Casteelo is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old May 29th, 2020, 10:21 PM   #2 (permalink)
Senior Member
 

Name: Kyle
Join Date: Jan 2018
Location: Ohio
Vehicle: 2006 Eclipse GS Auto
Posts: 1,606
Rep Power: 4
pcfreak4 has a spectacular aura about
So how is no oil related to ECU failure?
pcfreak4 is offline   Reply With Quote Quick reply to this message
Old May 29th, 2020, 10:54 PM   #3 (permalink)
Junior Member
 

Join Date: May 2020
Posts: 2
Rep Power: 1
Casteelo is on a distinguished road
Quote:
Originally Posted by pcfreak4 View Post
So how is no oil related to ECU failure?
Thats a great question. I was just giving a background of what happened, the cars got oil now.
Casteelo is offline   Reply With Quote Quick reply to this message
 
Old May 29th, 2020, 10:59 PM   #4 (permalink)
Senior Member
 

Name: Kyle
Join Date: Jan 2018
Location: Ohio
Vehicle: 2006 Eclipse GS Auto
Posts: 1,606
Rep Power: 4
pcfreak4 has a spectacular aura about
Quote:
Originally Posted by Casteelo View Post
Quote:
Originally Posted by pcfreak4 View Post
So how is no oil related to ECU failure?
Thats a great question. I was just giving a background of what happened, the cars got oil now.
How much oil did you have to add?
pcfreak4 is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Club4G Forum : Mitsubishi Eclipse 4G Forums - 2006-2012 Eclipse Authority forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
Real Name
What name do you go by?
Location
Where you live.
Type of Car
Year/Model/Trim
Insurance
Please select your insurance company (Optional)

Log-in



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 09:52 PM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Search Engine Friendly URLs by vBSEO
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
Ad Management plugin by RedTyger