Clicking - Club4G Forum : Mitsubishi Eclipse 4G Forums - 2006-2012 Eclipse Authority
Support Our Troops!         
 

Go Back   Club4G Forum : Mitsubishi Eclipse 4G Forums - 2006-2012 Eclipse Authority > Performance and Technical > Wheels, Tires, Brakes and Suspension

Wheels, Tires, Brakes and Suspension Slip and slide discussion


Welcome to the Club4G Forums where you can join fellow owners from all over North America discussing anything related to the 2006+ Mitsubishi Eclipse. You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. To gain access to post topics, communicate privately with other members (PM), respond to polls, upload content, you must register today!

  • Participate in over 100 specialized forums!
  • Get event information regarding meets, mod days and help in our regionalized forums.
  • Gain access to our classified marketplace to buy, sell or trade parts.
  • Levarage a vast collection of Do-It-Yourself guides on steps on working on your Eclipse
  • Access to the growing online parts directory which gives you insight on available parts and the vendors that carry them.
  • Communicate privately with other owners.

All of this and much more is available to you absolutely free when you register for an account. Sign up today!

If you have any problems with the registration process or your account login, please contact contact us.
Reply
 
LinkBack Thread Tools Display Modes
Old October 13th, 2018, 02:43 PM   #1 (permalink)
Junior Member
 

Name: patrick
Join Date: Sep 2018
Location: indiana
Vehicle: 2012 eclipse gs sport
Posts: 19
Rep Power: 2
kilala311 is on a distinguished road
Clicking

So I've seen only one post about this and I'm in school going for auto tech so I've asked my teacher about this , but when I turn at lower speeds there is a clicking from my back driver wheel. It also happens on smaller bumps. It doesnt happen all the time but I cant figure out what is causing it. I just got brand new tires last week and i think that's when it started
kilala311 is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old October 13th, 2018, 06:42 PM   #2 (permalink)
Senior Member
 
NamelessFoe's Avatar
 

Name: Chris
Join Date: Mar 2018
Location: New Jersey
Vehicle: 2006/Eclipse/GS
Posts: 516
Rep Power: 3
NamelessFoe will become famous soon enough
sounds like ball joint to me. I'd jack the car up and see if the tire has any play in it.
NamelessFoe is offline   Reply With Quote Quick reply to this message
Old October 15th, 2018, 12:17 AM   #3 (permalink)
Junior Member
 

Name: patrick
Join Date: Sep 2018
Location: indiana
Vehicle: 2012 eclipse gs sport
Posts: 19
Rep Power: 2
kilala311 is on a distinguished road
Quote:
Originally Posted by NamelessFoe View Post
sounds like ball joint to me. I'd jack the car up and see if the tire has any play in it.
Already tried that. It only happens when I'm in like a parking lot or taking off , all the suspension doesnt have play , ball joint it fine wheel hub is fine. Doesnt make the noise when I have my foot on the break though
kilala311 is offline   Reply With Quote Quick reply to this message
 
Old October 15th, 2018, 06:29 AM   #4 (permalink)
Senior Member
 
Joshinator99's Avatar
 

Name: Josh
Join Date: Feb 2018
Location: Massachusetts
Vehicle: 2006 Eclipse GS
Posts: 283
Rep Power: 3
Joshinator99 is on a distinguished road
Hmmm, sway bar end link?
__________________
2017 Chevy Camaro SS A8 6.2L DI V8, Whipple supercharger, 95mm TB, 5 CAI, AWE Tuning dual 3 exhaust, DSX E85 kit, 3.5 GForce Al driveshaft, 608 WHP/610 WTQ, [email protected]
2019 Toyota Sequoia Limited A6 5.7L V8, 381 HP, 4WD, 20 wheels. Daily driver.
2018 Alfa Romeo Ti Sport Q4 A9 AWD, Carbon fiber driveshaft, adaptive suspension, 19s.
Joshinator99 is offline   Reply With Quote Quick reply to this message
Old October 15th, 2018, 09:30 AM   #5 (permalink)
Junior Member
 

Name: patrick
Join Date: Sep 2018
Location: indiana
Vehicle: 2012 eclipse gs sport
Posts: 19
Rep Power: 2
kilala311 is on a distinguished road
Quote:
Originally Posted by Joshinator99 View Post
Hmmm, sway bar end link?
ive had it lifted and checked the suspension and it all seems correct and alright, my teacher said it may be a brake pad walking or shifting. it started right after i put on tires and its on the side with a bent rim so that may be causing it as well
kilala311 is offline   Reply With Quote Quick reply to this message
Old October 15th, 2018, 08:18 PM   #6 (permalink)
Senior Member
 
NamelessFoe's Avatar
 

Name: Chris
Join Date: Mar 2018
Location: New Jersey
Vehicle: 2006/Eclipse/GS
Posts: 516
Rep Power: 3
NamelessFoe will become famous soon enough
If you floor it and get a bad click, it could be your Trailing arms bushings, since flooring it would make the rear tires pull back as they start to move. But the clicking on bumps sounds like your ball joint has up and down play. Have you checked all your caliper bolts? guide pins and bracket bolts to see if they came loose? An end link would give you a clicking noise through everything the suspension hits.
NamelessFoe is offline   Reply With Quote Quick reply to this message
Old October 18th, 2018, 10:21 AM   #7 (permalink)
Junior Member
 

Name: patrick
Join Date: Sep 2018
Location: indiana
Vehicle: 2012 eclipse gs sport
Posts: 19
Rep Power: 2
kilala311 is on a distinguished road
Quote:
Originally Posted by NamelessFoe View Post
If you floor it and get a bad click, it could be your Trailing arms bushings, since flooring it would make the rear tires pull back as they start to move. But the clicking on bumps sounds like your ball joint has up and down play. Have you checked all your caliper bolts? guide pins and bracket bolts to see if they came loose? An end link would give you a clicking noise through everything the suspension hits.
i havent yet but i will thats a good idea we felt around and nothing felt loose but i will pull it apart and check
kilala311 is offline   Reply With Quote Quick reply to this message
Old October 21st, 2018, 02:06 PM   #8 (permalink)
Junior Member
 

Name: patrick
Join Date: Sep 2018
Location: indiana
Vehicle: 2012 eclipse gs sport
Posts: 19
Rep Power: 2
kilala311 is on a distinguished road
So I've tried tightening the caliper it isnt that and I'm at a complete loss
kilala311 is offline   Reply With Quote Quick reply to this message
Old October 21st, 2018, 03:36 PM   #9 (permalink)
Senior Member
 
NamelessFoe's Avatar
 

Name: Chris
Join Date: Mar 2018
Location: New Jersey
Vehicle: 2006/Eclipse/GS
Posts: 516
Rep Power: 3
NamelessFoe will become famous soon enough
i would find a bumpy parking lot and have a friend walk next to the car on all sides to see if it''s actually coming from the rear or front. Weird to constantly have a clicking noise you can't find the source of.
NamelessFoe is offline   Reply With Quote Quick reply to this message
Old October 22nd, 2018, 01:17 AM   #10 (permalink)
Junior Member
 

Name: patrick
Join Date: Sep 2018
Location: indiana
Vehicle: 2012 eclipse gs sport
Posts: 19
Rep Power: 2
kilala311 is on a distinguished road
I will try that , because I've taken that rear tire off and I cant find any source . I kind of have a hunch it is cause by the rim. It is bent and it started when I replaced all the tires
kilala311 is offline   Reply With Quote Quick reply to this message
Old October 24th, 2018, 02:55 PM   #11 (permalink)
Senior Member
 

Name: Kevin
Join Date: Apr 2015
Location: Tampa
Vehicle: 2008 Eclispe GT 6MT
Posts: 143
Rep Power: 5
#TampaEclipse is on a distinguished road
Could be a wheel bearing, which would necessitate replacing the wheel hub.
#TampaEclipse is offline   Reply With Quote Quick reply to this message
Old November 5th, 2018, 12:00 PM   #12 (permalink)
Junior Member
 

Name: patrick
Join Date: Sep 2018
Location: indiana
Vehicle: 2012 eclipse gs sport
Posts: 19
Rep Power: 2
kilala311 is on a distinguished road
Quote:
Originally Posted by #TampaEclipse View Post
Could be a wheel bearing, which would necessitate replacing the wheel hub.
yea thats what im thinking it is. Im going to fix that wheel hub and see where that takes me
kilala311 is offline   Reply With Quote Quick reply to this message
Old November 5th, 2018, 10:47 PM   #13 (permalink)
Senior Member
 
NamelessFoe's Avatar
 

Name: Chris
Join Date: Mar 2018
Location: New Jersey
Vehicle: 2006/Eclipse/GS
Posts: 516
Rep Power: 3
NamelessFoe will become famous soon enough
Quote:
Originally Posted by kilala311 View Post
I will try that , because I've taken that rear tire off and I cant find any source . I kind of have a hunch it is cause by the rim. It is bent and it started when I replaced all the tires
Bent rims could mean damaged hub. But usually you get a grinding or whirling noise. Or the sound of road noise gets very loud. Starting to wonder if something is loose in your spare tire compartment.
NamelessFoe is offline   Reply With Quote Quick reply to this message
Old November 6th, 2018, 12:20 PM   #14 (permalink)
Junior Member
 

Name: patrick
Join Date: Sep 2018
Location: indiana
Vehicle: 2012 eclipse gs sport
Posts: 19
Rep Power: 2
kilala311 is on a distinguished road
Quote:
Originally Posted by NamelessFoe View Post
Bent rims could mean damaged hub. But usually you get a grinding or whirling noise. Or the sound of road noise gets very loud. Starting to wonder if something is loose in your spare tire compartment.
like what would be loose because it comes from outside, i believe the noise is traveling from the passenger because of the wheel hub. i have got the rims fixed but there is still a bit of road noise too and can be loud on certain roads
kilala311 is offline   Reply With Quote Quick reply to this message
Old November 6th, 2018, 06:37 PM   #15 (permalink)
Senior Member
 
NamelessFoe's Avatar
 

Name: Chris
Join Date: Mar 2018
Location: New Jersey
Vehicle: 2006/Eclipse/GS
Posts: 516
Rep Power: 3
NamelessFoe will become famous soon enough
you'd be surprised where the sound is actually coming from when you are driving. If you still haven't found it i'd bring it to an old time mechanic, they usually know car sounds better than anyone.
NamelessFoe is offline   Reply With Quote Quick reply to this message
Old November 7th, 2018, 08:28 PM   #16 (permalink)
Junior Member
 
Satin Meisai Gray Pearl's Avatar
 

Name: Rob
Join Date: Apr 2012
Location: New Hampshire
Vehicle: 2007 Eclipse Spyder GT
Posts: 15
Rep Power: 8
Satin Meisai Gray Pearl is on a distinguished road
My 2007 was making a clicking noise, (front passenger side). Took it to a mechanic who replaced a bad axel shaft. No more clicking. Not too expensive of a repair either.
Satin Meisai Gray Pearl is offline   Reply With Quote Quick reply to this message
Old November 9th, 2018, 02:25 PM   #17 (permalink)
Senior Member
 

Name: Kevin
Join Date: Apr 2015
Location: Tampa
Vehicle: 2008 Eclispe GT 6MT
Posts: 143
Rep Power: 5
#TampaEclipse is on a distinguished road
Quote:
Originally Posted by Satin Meisai Gray Pearl View Post
My 2007 was making a clicking noise, (front passenger side). Took it to a mechanic who replaced a bad axel shaft. No more clicking. Not too expensive of a repair either.
Our cars are FWD and do not have rear axles.
#TampaEclipse is offline   Reply With Quote Quick reply to this message
Old November 10th, 2018, 03:13 PM   #18 (permalink)
Super Moderator
 
iBlackSunday's Avatar
 

Name: Garrett
Join Date: Feb 2018
Location: Wisconsin
Vehicle: 2007 Eclipse GS Spyder
Posts: 248
Rep Power: 3
iBlackSunday is on a distinguished road
Clicking

I actually had something like this when I first started driving my car. I'd turn a corner, and I'd hear a thud. Was the tire iron envelope in the trunk.

Currently I have a thudding noise whenever I go over bumps. I'm assuming it's the strut mount and will be taking a look. Noises can sound like they're coming from one corner of the car and be at the totally opposite side. My first car had a bad driver side axel, replaced passenger side because it was 95% sure it was coming from that side. I was wrong and ended up replacing the driver side also.
__________________
Installed: DC Cold Air Intake | All Resonator Delete | Gutted Stock Exhaust | All Exterior + Interior LED

Maintenance: Timing belt-118k | Auto Trans Fluid-131k | Spark Plugs+Grommets+Valve Cover Gasket-125k | Passenger CV Axle-144k | Mag Oil Plug-153k

Future Work (12/10/2019): Replace Convertible Top

Last Oil Change-153,000
Valvoline 5w30 Full Synthetic + Bosch Oil Filter
iBlackSunday is offline   Reply With Quote Quick reply to this message
Old November 10th, 2018, 06:55 PM   #19 (permalink)
Senior Member
 
NamelessFoe's Avatar
 

Name: Chris
Join Date: Mar 2018
Location: New Jersey
Vehicle: 2006/Eclipse/GS
Posts: 516
Rep Power: 3
NamelessFoe will become famous soon enough
The Thud could be your front sway bar bushings, Currently dealing with it at the moment. Mine are frozen in place. So going to the shop Thursday to get ES bushing installed.
NamelessFoe is offline   Reply With Quote Quick reply to this message
Old November 12th, 2018, 09:06 AM   #20 (permalink)
Junior Member
 

Name: patrick
Join Date: Sep 2018
Location: indiana
Vehicle: 2012 eclipse gs sport
Posts: 19
Rep Power: 2
kilala311 is on a distinguished road
i have yet to replace the wheel hub, but i was out and kicked all my tires and heard that my front passenger has a sound kinda like the clicking
kilala311 is offline   Reply With Quote Quick reply to this message
Old November 12th, 2018, 03:02 PM   #21 (permalink)
Senior Member
 
NamelessFoe's Avatar
 

Name: Chris
Join Date: Mar 2018
Location: New Jersey
Vehicle: 2006/Eclipse/GS
Posts: 516
Rep Power: 3
NamelessFoe will become famous soon enough
Keep up on it. If it is in fact a wheel hub. If that breaks at highway speeds it's not going to be pretty.
NamelessFoe is offline   Reply With Quote Quick reply to this message
Old November 12th, 2018, 04:56 PM   #22 (permalink)
Junior Member
 
Satin Meisai Gray Pearl's Avatar
 

Name: Rob
Join Date: Apr 2012
Location: New Hampshire
Vehicle: 2007 Eclipse Spyder GT
Posts: 15
Rep Power: 8
Satin Meisai Gray Pearl is on a distinguished road
Quote:
Originally Posted by #TampaEclipse View Post
Our cars are FWD and do not have rear axles.
I'm well aware that these cars are FWD. I didn't say that I replaced the rear axle, I said I had the Axle Shaft replaced on the front passenger side. There is also one on the front driver's side. An axle shaft is different than a rear axle. Google is a great tool if you use it.

Last edited by Satin Meisai Gray Pearl; November 12th, 2018 at 04:59 PM.
Satin Meisai Gray Pearl is offline   Reply With Quote Quick reply to this message
Old November 26th, 2018, 06:20 AM   #23 (permalink)
Junior Member
 

Name: patrick
Join Date: Sep 2018
Location: indiana
Vehicle: 2012 eclipse gs sport
Posts: 19
Rep Power: 2
kilala311 is on a distinguished road
i fixed the wheel hub, when doing that i turned the wheel on the driver side rear and there is something in the tires so i found the source of the noise. i haven't taken it out yet but it makes sense on why it started once i got the new tires put on.
kilala311 is offline   Reply With Quote Quick reply to this message
Old November 26th, 2018, 05:06 PM   #24 (permalink)
Senior Member
 
NamelessFoe's Avatar
 

Name: Chris
Join Date: Mar 2018
Location: New Jersey
Vehicle: 2006/Eclipse/GS
Posts: 516
Rep Power: 3
NamelessFoe will become famous soon enough
lmao, $20 says they didn't fully remove the old stub for air. or your tire pressure sensor is done.
NamelessFoe is offline   Reply With Quote Quick reply to this message
Old November 27th, 2018, 08:24 AM   #25 (permalink)
Senior Member
 

Name: Kevin
Join Date: Apr 2015
Location: Tampa
Vehicle: 2008 Eclispe GT 6MT
Posts: 143
Rep Power: 5
#TampaEclipse is on a distinguished road
Quote:
Originally Posted by Satin Meisai Gray Pearl View Post
I'm well aware that these cars are FWD. I didn't say that I replaced the rear axle, I said I had the Axle Shaft replaced on the front passenger side.
Not sure how I missed that. Need to spend some XP on my literacy skill.
#TampaEclipse is offline   Reply With Quote Quick reply to this message
Old November 27th, 2018, 08:34 AM   #26 (permalink)
Junior Member
 

Name: patrick
Join Date: Sep 2018
Location: indiana
Vehicle: 2012 eclipse gs sport
Posts: 19
Rep Power: 2
kilala311 is on a distinguished road
Quote:
Originally Posted by NamelessFoe View Post
lmao, $20 says they didn't fully remove the old stub for air. or your tire pressure sensor is done.
well i had them put a tpms on when i did the tires since i was missing one and they probably left the old regular air valve in the tire
kilala311 is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Club4G Forum : Mitsubishi Eclipse 4G Forums - 2006-2012 Eclipse Authority forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
Real Name
What name do you go by?
Location
Where you live.
Type of Car
Year/Model/Trim
Insurance
Please select your insurance company (Optional)

Log-in



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
No start with clicking noise/will start rarely stevenlg Problem Reports 62 July 28th, 2018 03:17 PM
Continuous clicking noise when clutch is released CanadianBacon Problem Reports 7 June 2nd, 2017 02:53 PM
Clicking noise when driving - Need input! willem445 2006-2012 Eclipse (General 4G) 3 July 1st, 2016 12:59 AM
Clicking sound in accessory mode moses1227 2006-2012 Eclipse (General 4G) 1 June 24th, 2015 03:45 PM
2001 Eclipse won't start, fusebox clicking Egememnon Problem Reports 2 July 1st, 2014 11:27 PM


All times are GMT -5. The time now is 12:12 AM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Search Engine Friendly URLs by vBSEO
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
Ad Management plugin by RedTyger