I have a question Anybody have any advice? - Club4G Forum : Mitsubishi Eclipse 4G Forums - 2006-2012 Eclipse Authority
Support Our Troops!         
 

Go Back   Club4G Forum : Mitsubishi Eclipse 4G Forums - 2006-2012 Eclipse Authority > Performance and Technical > Wheels, Tires, Brakes and Suspension

Wheels, Tires, Brakes and Suspension Slip and slide discussion


Welcome to the Club4G Forums where you can join fellow owners from all over North America discussing anything related to the 2006+ Mitsubishi Eclipse. You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. To gain access to post topics, communicate privately with other members (PM), respond to polls, upload content, you must register today!

  • Participate in over 100 specialized forums!
  • Get event information regarding meets, mod days and help in our regionalized forums.
  • Gain access to our classified marketplace to buy, sell or trade parts.
  • Levarage a vast collection of Do-It-Yourself guides on steps on working on your Eclipse
  • Access to the growing online parts directory which gives you insight on available parts and the vendors that carry them.
  • Communicate privately with other owners.

All of this and much more is available to you absolutely free when you register for an account. Sign up today!

If you have any problems with the registration process or your account login, please contact contact us.
Reply
 
LinkBack Thread Tools Display Modes
Old June 26th, 2019, 07:19 AM   #1 (permalink)
Junior Member
 

Name: jake
Join Date: Aug 2017
Location: Rolla,Mo.
Vehicle: 2006 eclipse GT
Posts: 6
Rep Power: 3
13lacksoul is on a distinguished road
Anybody have any advice?

So a while ago my 06 gt got in a bit of an accident and slapped the curb sideways pretty hard and the bottoms of my wheels were pushed in pretty good put a bunch of new parts on it new rims rear trailing arm toe control arm front lower control arm when I got the wheels somewhat back in alignment I have this rubbing sound when I turn right but not left coming from opposite side of impact I've changed the wheel bearing and that side CV Axel and nothing takes away the rubbing sound when a right turn is made and for the life of me can't find any rub marks any suggestions?
13lacksoul is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old June 26th, 2019, 06:57 PM   #2 (permalink)
Senior Member
 
NamelessFoe's Avatar
 

Name: Chris
Join Date: Mar 2018
Location: New Jersey
Vehicle: 2006/Eclipse/GS
Posts: 516
Rep Power: 3
NamelessFoe will become famous soon enough
did you check to make sure the front sway bar end links weren't bent?
NamelessFoe is offline   Reply With Quote Quick reply to this message
Old June 27th, 2019, 01:40 PM   #3 (permalink)
Junior Member
 

Name: jake
Join Date: Aug 2017
Location: Rolla,Mo.
Vehicle: 2006 eclipse GT
Posts: 6
Rep Power: 3
13lacksoul is on a distinguished road
I didn't check those no do you think that would make a rubbing sound it sounds just like a tire rubbing something but no rub marks anywhere
13lacksoul is offline   Reply With Quote Quick reply to this message
 
Old June 27th, 2019, 05:33 PM   #4 (permalink)
Senior Member
 
NamelessFoe's Avatar
 

Name: Chris
Join Date: Mar 2018
Location: New Jersey
Vehicle: 2006/Eclipse/GS
Posts: 516
Rep Power: 3
NamelessFoe will become famous soon enough
If the end link is bent it could allow your car to roll over enough to make contact with the tire. You could also check your tie rod inner and outer to see if it was damaged. could be making the power steering pump work harder.
NamelessFoe is offline   Reply With Quote Quick reply to this message
Old July 1st, 2019, 08:21 AM   #5 (permalink)
Junior Member
 

Name: jake
Join Date: Aug 2017
Location: Rolla,Mo.
Vehicle: 2006 eclipse GT
Posts: 6
Rep Power: 3
13lacksoul is on a distinguished road
Thank you I will check on those gonna put a new wheel bearing on as well so I'll already be in there will post what I find when I dig in!thanks again.
13lacksoul is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Club4G Forum : Mitsubishi Eclipse 4G Forums - 2006-2012 Eclipse Authority forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
Real Name
What name do you go by?
Location
Where you live.
Type of Car
Year/Model/Trim
Insurance
Please select your insurance company (Optional)

Log-in



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 12:50 AM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Search Engine Friendly URLs by vBSEO
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
Ad Management plugin by RedTyger