Mitsubishi Eclipse 4G Forums banner

acceleration

  1. Problem Reports
    Hi Need some advice. 2007 2.4l 275K miles I've owned the car since 2010, 33K miles. I've had great luck with this car, no major issues ever, except for the brakes randomly going out on me about 2 years ago-which was fixed with a recall. Not sure if any of this is related. I screwed up...
  2. Eclipse Performance
    Hi everyone, I've creeped these forums for a couple of years since getting my Eclipse for ideas on what's working for others and what I should avoid. About a year ago I saw both the AWD Eclipse that's been created and a video on a Civic Type-R with in-hub electric motors on the rear wheels to...
  3. New Members Forum
    hello my name is james im from san antonio i have a 2008 eclipse that i recently put a turbo on its been having a rough idle and dying and lack of acceleration when i step on the gas from a complete stop it had some codes that came up to be the purge control valve and multiple misfires i was...
  4. CariD.com
    Versus rims is a 100% Australian owned and operated brand with over 20 years of experience in the wheel industry. Today the company produces racing and luxury monoblock and multi-piece forged wheels that combine technical perfection with stylish design. They feature a strong yet lightweight...
  5. Problem Reports
    Hello, my 06 gs 2.4L will not properly go into 4th gear. All other gears work as they should. But when I shift into 4th gear and give acceleration the gear shifter slams into the neutral position... I’ve noticed that if I granny shift into 4th gear and hold the shift knob for about 3-4 seconds...
  6. 2006-2012 Eclipse (General 4G)
    Greetings. I have a 2107 Spyder GT with 98.5K miles and manual transmission. Service Engine Soon light is not lit. However, I get a B1318 code that the scanner calls "Valve Actuation." There is no listing for that code in the factory service manual. If I clear it, it comes right back after one...
  7. Tuning and Electronics
    There's already been quite a few reviews of Stayer's tune, but here's another with additional details for those still on the fence or shopping for a reflash. As mentioned in another thread, I had been dealing with codes of late, having installed RRE headers a year ago. I was waiting to pass...
  8. 2006-2012 Eclipse (General 4G)
    I recently changed OBD bluetooth adapters, and two days later, my battery was dead. I then noticed that when I put my fingers on the port itself, I feel tingling, so I believe the wires are crossed, even though the new adapter has been working fine the entire time. The port is right above the...
  9. 2006-2012 Eclipse (General 4G)
    So notice this after a hard acceleration and now it does it off and on even when not accelerating. But I have a handful of whites coming on they blink on and shut off I'm pretty sure my car is having a stroke. any ideas? Videos being uploaded to YouTube right now will post as soon as it's...
  10. Problem Reports
    2006 GS 2.4 coupe Recently the car broke the teeth off the timing belt, took a bit to figure out that was the issue but first replaced the fuel pump, then noted the cam was not spinning when it still wouldn't start. Replaced the timing belt and water pump Car ran fine for a couple weeks, then...
  11. 2006-2012 Eclipse (General 4G)
    https://youtu.be/rQLEAWvkaAE Video shows what I’m dealing with. Only happens on acceleration or above 4.5k RPM’s. I think it’s a fuel issue because of it happens almost constantly above 4.5k RPMs. Also, because 1 out of maybe 75 starts it fails to start until I try and start again. Doesn’t...
  12. 4G Eclipse GS/SE Specific
    so at my work yesterday my Master Tech installed my headers and my magnaflow exhaust on my car. we even gutted the cat on the bottom by installing a 2.25" pipe and some band clamps. overall it sounds amazing, just now it has the idle issues along with the acceleration. thankfully I made it home...
  13. Interior and Exterior Modifications (Show)
    Alrighty, so i am having a hard time deciding whether i want to buy some coil overs or a carbon fiber hood. My thoughts on both for you to help me decide. I'm already sitting on tein s-tech springs soooo! If i buy a hood i will be able to vent all that excess heat out and get rid of some...
  14. 2006-2012 Eclipse (General 4G)
    So Ive a 2007 Eclipse GS 5 speed. When I accelerate fairly intensely, the RPM goes super high 5000+ but the car barely gains any speed. On the other hand, if I accelerate slowly and uniformly, it gains speed normally. What could be the reason? Slipping transmission, fuel pump? The clutch change...
  15. Driveline
    So, I have a few problems with my driveline - I think. 2007 GS - 5MTX 1. My gears grind if I shift too quickly. There doesn't seem to be specific gears that do it, but I've noticed it on gears 2,3 and 5. 2. When I let off and reapply gas, there's a jerk each time. When I let off, there is a...
  16. 4G Eclipse GS/SE Specific
    Interested in more street relevant power(acceleration). Wondering if anyone has gotten there 0-60 to around 5 seconds on the GS model, and if you did how did you do it?
  17. Problem Reports
    RESOLVED :Rumbling / rattling when accelerating EGR PIPE Hey all I am new to this forum, I just made an account but have been reading threads since I bought my eclipse in 2015. 2008 gt eclipse A few months ago i received a check engine code for spark plugs so I changed the front 3 plugs on...
  18. Cars For Sale/Wanted
    2012 Mitsubishi Eclipse GS Sport - $6500 Great condition! This is last year the Eclipse is made. 2.4L 4 Cylinder, Automatic (with Sportronic Mode, manual shift gate) 104,000 odometer New built engine only has 7000 miles on it, runs PERFECT! Power Windows, Power Locks Remote Entry 4 Wheel Disc...
  19. Eclipse Performance
    Good day everyone, Recently i have installed the DC CAI to my 2009 V6 Eclipse, and since installing the DC Kit, and started pushing the car, i indeed noticed significant performance changed through the different RPM range. 1- Low End Torque: - I define this below 3000 RPM, and i started to...
  20. Problem Reports
    Hey all, I've been scouring the forums here for a solution, but I've come across a lot of mixed reports in various threads. This seems to be a sort-of common issue. Model: 2008 GS (everything stock), 95,000 miles, all my own. Problem: Rattling/Whirring/Shuddering noise when clutch pedal...
Top