Mitsubishi Eclipse 4G Forums banner

check engine light

  1. Problem Reports
    Hi Need some advice. 2007 2.4l 275K miles I've owned the car since 2010, 33K miles. I've had great luck with this car, no major issues ever, except for the brakes randomly going out on me about 2 years ago-which was fixed with a recall. Not sure if any of this is related. I screwed up...
  2. Problem Reports
    I'll just explain everything and you can straighten me out... 2007 Eclipse 4 cyl auto trans, 215K miles. I'm driving and the car suddenly goes into 3rd gear. D on the dashboard is blinking. I putt putt to my work and turn it off. Later in the day I come out and everything is now fine. Go...
  3. Problem Reports
    I have a 2009 with the 2.4L that after pulling into the driveway the other night the check engine light came on and it started idling rough as hell. I shut it off and restarted it. It started back up but ran rough as hell, tach was at around 1000rpms but it felt like 150-200, it would finally...
  4. Cars For Sale/Wanted
    Ladies and Gentlemen, It is with some sadness that I post this. I purchased my 2006 GT as a present to myself after returning from a deployment to Iraq in 2012. When I purchased her she was bone stock with (as far as I can tell) every available option available in 2006. Sun and sound...
  5. 2006-2012 Eclipse (General 4G)
    Hi guys, I’ve been having a mystery issue here that I am having some issues diagnosing. I can provide extra info if it might help. A couple of weeks ago the car would not start but if I took the key out and put it back in then it would with no issues. It doesn’t crank or anything when it...
  6. 4G Eclipse GT/SE Specific
    Just had my check engine light come on, looked up both these errors and I'm hoping the P0137 is causing the PO431 error and it's not a cat problem again. Just replaced my cat 1.5 years ago with a expensive OEM which I regret at this point. I'm guessing it's not the same cat since the eclipse has...
  7. Problem Reports
    good morning guys, I'm new to the forum, I'm sorry if this is not the right place to post about a problem I'm having with my car, 2007 Eclipse GS 4 cylinders (2.4) runs great but at times it dies on me I could driving down the road with my foot in the gas pedal and it dies, or I could be in a...
  8. Problem Reports
    The P0102 code is the MAF circuit low input code. For me it threw a check engine light and the car wouldn't stay running unless I gave it gas. Ran super rough otherwise. The TCL light also comes on. I'm guessing anytime the car is running bad the TCL light probably comes on, because the 4G...
  9. Problem Reports
    2009 2.4. 130,000 miles Background: changed timing belt/balancer belt. Original tensioner left in it. After 5000 miles, oil light would flicker during idle. Checked oil level, full, didnt worry about it. 10,000 miles later, oil leaking on ground. Just maintained oil level for 1 year (2,000)...
  10. 2006-2012 Eclipse (General 4G)
    My car displayed the Check Engine Light today and I used an AutoLink scanner to check. I have the P0031 - HO2S Heater Control Circuit Low Bank 1 Sensor 1 message. I was able to locate all four sensors, but I don't know which one is for Bank 1 Sensor 1. Please help me find the correct sensor...
  11. 4G Eclipse GS/SE Specific
    I have a 2008 gs convertible with 147000 miles. I had a problem that previously disappeared but has now reared its head again. While driving for no reason all of a sudden the check engine light comes on while the speedometer and tach goes to zero. The odometer also no longer advances. The car...
  12. 2006-2012 Eclipse (General 4G)
    hi how do I fix the problem with o2 senor power … I keep have this problem .. once in a wild the check engine light will come on and I check it out saying that there not enough power to the o2 sensor help pls ..???
  13. Problem Reports
    I have a 2006 eclipse GT that I purchased as a weekend project car. Here is the issue and what I have done. The car will start and run but it will seem as it is running out of fuel then shut off. This can happen at any point sometimes within 30 seconds of starting or after driving for 2 miles...
  14. 4G Eclipse GS/SE Specific
    I bought a 2007 Eclipse GS a few months ago and I've already driven it about 5000 kilometers. At first I thought it was good, but after driving it for a little bit it doesn't feel powerful at all anymore. I timed a few 0-60 runs and I'm averaging about 10 seconds. Even downshifting then putting...
  15. Problem Reports
    My asc off and check engine lights started coming on randomly sometimes its just asc off and no engine light. I have 3rd cat delete to straight pipe and a DC sports CAI :dunno::dunno:
  16. 2006-2012 Eclipse (General 4G)
    I have owned my eclipse since 2014, right after I got it the check engine light came on, I could reset it, but eventually it would come back. It finally got to the point where I had to do something about it to pass DEQ. I ended up going with a OEM cat, the mechanic was looking at it and said the...
  17. Problem Reports
    Hey guys, I don’t know how to use this too well, so I’m sorry if I’m posting this in the wrong place... Anyways, I have an ‘07 GT 6 speed and today while I was driving home from Orlando on the turnpike, I noticed my car wouldn’t go past 5k? It started doing this today. I noticed when I wanted...
  18. New Members Forum
    Thank you for your interest I'm a first time mitsubishi own I bought this car for cheep 2000 mitsubishi eclipse 4 cylinder automatic transmission. It had a check engine light but guy said well the parts in the car just pop it in should solve the issue sounded great. I took the car to a garage...
  19. New Members Forum
    Good evening, Love(d) my 2011 6 cylinder sport Eclipse... Last week my battery totally died while I was out of town. I came home, jumped the battery and put article charger on battery. I put a new battery in it too...but no change to the following problems. The car now runs rough, stutters...
  20. 2006-2012 Eclipse (General 4G)
    :69:Hello new Mitsubishi eclipse owner 09 eclipse 2.4 a/t. 188,200 odometer. 2wks ago on my way from work I lost power suddenly, i pulled to the side and the shut car off.tried starting again now wont start.checked tbelt & everything is ok there, check engine light on.dtc for p0123 circuit a...
Top