Mitsubishi Eclipse 4G Forums banner

defrost

  1. 4G Eclipse GT/SE Specific
    Okay...my first post and I know I am a noob and I promise I just spent 30 minutes searching the whole forum. :D So...I notice some power loss when the A/C compressor is running. Always been that way. I know that on all cars the compressor will run even when the A/C is off when the selector is...
  2. Problem Reports
    Hello all! When I turn on my fan, I get a noise that sounds like there's a leaf stuck somewhere in my duct system (which is possible, that vent thing under my wipers IS broken) but a friend of mine is having the same problem and he said he researched it down to something called a blend door...
  3. Problem Reports
    I am having trouble with my rear defrost. A section of it doesn't work. Hopefully the picture shows it well enough. Could this be due to part of it being unplugged, or is it more likely to be something broken? It doesn't bother me enough to have the window replaced, but I would be willing to rip...
  4. Problem Reports
    Haven't found much in detail. Driver side floor stays wet when a/c or defrost is on. Have an Idea that it might be the drain for the a/c evaporator is clogged. A little more info and detail on where it is located would be grateful.
  5. 2006-2012 Eclipse (General 4G)
    Looking for a couple parts here. Not sure exactly what they are, because they are missing on my car. One of them is the rear defrost button, the other is the same button, but on the opposite side of the fan control knob. If anyone can get me like a napa link, or autozone link, would be GREATLY...
  6. Problem Reports
    I seem to have this issue with my A/C. It will turn on when on speed 1. I have a green light, compressor kicks on the works. As soon as I turn it past 1, I get no lights, not even a blue light, and the compressor shuts off. Now, the search I did says it is the blower motor resister, but I do...
  7. Problem Reports
    Lately I've been hearing a clicking noise whenever I turn on the ac heater or defrost. Still blew air cold and hot. Today I try to turn on the defrost and no air. Heater...no air. Ac...no air. After driving for about 3 minutes I try to on the defrost and it finally turns on and clicking noise is...
  8. Problem Reports
    ok so i have kind of looked on the threads and didn't see this question yet.. so here goes. 07 GS .. its winter time and i let the car warm up no problems. heat defrost the window and all is well.. now my question is.. when driving it blows nice hot air out the vents. but when i stop.. like at a...
  9. Problem Reports
    I have a 2009 GT Spyder that started out intermittent where air/heat/defrost didn't blow out. After trying the knobs and switching between the settings, it came back on and worked for a couple months. Then it decided to go out again but fiddling with the knobs it came back on for a day. Now it...
  10. Problem Reports
    There a couple of other threads for this, but the OP's quit before there was a resolution or an explanation. When I turn on my rear window defroster, my radio turns into a loud static-y mess. I assume that this is because the antenna is in the defroster, but it shouldn't be doing that. Is...
Top