Mitsubishi Eclipse 4G Forums banner

fuel pump

  1. Problem Reports
    Hi everyone. So im having a weird electrical issue that is affecting my idle a bit. I recently replaced with an ACDelco reman alternator and it was running so clean until after my first 60 mile road trip. Here's the symptoms. At idle, my fuel pump is obviously oscillating causing somewhat...
  2. Problem Reports
    I've got something going on with my Eclipse 4G, and I can't figure out what it is. I'm trying to avoid taking it to a shop and blowing 500% more money than what the repair is worth on mechanics time and repairing parts that aren't the problem. So I thought I'd ask here first. Here's the deal...
  3. Club4g AutoGuide Forum Support / Help
    does the supply hose that hooks up to the side of pump have a filter beside the one in the pump, just want to be sure I have everything needed before starting
  4. Club4g AutoGuide Forum Support / Help
    How do you unclip the connector on the pressure regulator on top of fuel pump, it's the one with the wire retainer around it?
  5. 2006-2012 Eclipse (General 4G)
    Hey everyone, Was driving to Mickey Shorr and my service engine soon light came on half way there. Took it to AutoZone for a free code read right after and looks like I forgot my gas cap at a fuel pump :/ No problem though, since I went online and bought a Duralast gas cap that said it fits a...
  6. 2006-2012 Eclipse (General 4G)
    For those who have yet to suffer through this, a few tips I learned through my experience! – Earlier this year, we bought the car used, knowing it was from up north and was rusty underneath. The only real problem we’ve had so far was the fuel tank started leaking from the two vent lines on top...
  7. New Members Forum
    I wanted to say Hello to the Forum and after reading a bit I cant find anyone with this specific problem but it could be some where I just have not found it yet. I have a 2008 Spyder GS and it just died in traffic the other day. I have zero fuel pressure. it is not my fuel pump. I know own...
  8. 4G Eclipse GS/SE Specific
    Hey guys, I've recently been having a problem with getting my 2011 Eclipse GS automatic to start. I was wondering if anyone has had the same problem or has any idea what the problem could be before I take it in to a mechanic. When I start, the engine turns over and starts, but has a very rough...
  9. 2006-2012 Eclipse (General 4G)
    Hi Folks, I have been a 4G GS owner since 2006 and was on the forum way back then. The car has never been back to the shop as I do all my own maintenance. I need to get the brake recall done, but that's another story. I just had my timing belt break on the way to work the other day and of...
  10. Problem Reports
    Hopefully someone has an answer for my really obscure problem I've been troubleshooting. So I just did an engine swap, and now when I turn the key to "On", power is alright. The ECU is getting 12v, ECU grounds are good, body grounds are good, trans ground is good. However, when I turn it to...
  11. 2006-2012 Eclipse (General 4G)
    Hey everyone, Can someone carefully explain to me why I can't just go on eBay and buy a shitty civic turbo kit and slap it on my eclipse with some custom fabrication and placement? Nobody has told me that this wouldn't work, I'm just assuming so because that would be wayyyy too easy. The kits...
  12. 2006-2012 Eclipse (General 4G)
    Hey guys, I was wondering about how well the 4cylinders would put up with mixing some E85 in the gas tank I know this is commonly done on Subaru WRX's because they require premium, so you GT Eclipse guys might be interested because of this. What people do for the WRX's is either mix E85 about...
  13. Forced Induction & Nitrous
    It's been awhile since i've posted but i feel the need to give a quick little list of parts required to build the 4g69 for boost. While you can stay around 10 lbs of boost on stock internals if you wanna go past that here is a list you will need. I did the research and will be building soon as...
  14. Eclipse Performance
    I'm looking to switch to a Fuel cell. But I can't find anywhere if i'm going to run into problems with the computer not controlling the fuel pump correctly, or even having an after rail regulator on there. Anyone ever run an external return style fuel on these cars. Any help would be greatly...
  15. Problem Reports
    I have a 2006 eclipse GT that I purchased as a weekend project car. Here is the issue and what I have done. The car will start and run but it will seem as it is running out of fuel then shut off. This can happen at any point sometimes within 30 seconds of starting or after driving for 2 miles...
  16. Problem Reports
    2006 GS 2.4 coupe Recently the car broke the teeth off the timing belt, took a bit to figure out that was the issue but first replaced the fuel pump, then noted the cam was not spinning when it still wouldn't start. Replaced the timing belt and water pump Car ran fine for a couple weeks, then...
  17. GS
    Hi everyone, I do not know if this is the right place to post this, if it is not, I apologize in advance. I have a turbo kit for sale for the GS version. Long story short I bought this second hand turbo kit but the turbo manifold was very damaged and could not be repaired, it took me a while to...
  18. 2006-2012 Eclipse (General 4G)
    Hey fellas, I bought my son a 2006 Eclipse GS for his first car. He’s pumped! Car needed some TLC, but started and ran fine when we bought it. We put it on a flatbed and brought it home (tires, brakes were too bad to drive IMO). Fast forward a few weeks after doing some general cosmetic...
  19. 2006-2012 Eclipse (General 4G)
    So Ive a 2007 Eclipse GS 5 speed. When I accelerate fairly intensely, the RPM goes super high 5000+ but the car barely gains any speed. On the other hand, if I accelerate slowly and uniformly, it gains speed normally. What could be the reason? Slipping transmission, fuel pump? The clutch change...
  20. Problem Reports
    Daily Driver, 105k Miles winter stored, New Timing Belt/Water pump Kit last I diagnosed it as a fuel pump, checked relays and all fuses came back clear, car is not showing any codes, fuel pump was not priming when car is in "on" nor when cranking. So I replaced the the fuel pump and both fuel...
Top