Mitsubishi Eclipse 4G Forums banner

gt 3.8

  1. New Members Forum
    Hello my name is Heyshar. I've been a member since last year. I didnt know how this worked so I have never write anything over here. Now I have a problem and I dont know if this is the right forum. But my car is a 08 Mitsubishi Eclipse gt 3.8 M/T. Im having problems trying to find the flywheel...
  2. New

    New Members Forum
    New member on the forum, but not new to the eclipse. I own a 2006 eclipse GT 3.8 6 Speed with all the basic bolt one (Headers, exhaust, and intake) nothing to special. I'm looking to either do a supercharged build or turbo build. Im Trying to get a good understanding of what is needed to do...
  3. 4G Eclipse GT/SE Specific
    I have a 2007 mitsubishi eclipse GT 3.8 and I got CEL and I had the code read and it was P0431 so I replaced all the 02 sensors still the light came back on after having it cleared so I begrudgingly replaced the back CAT (what a bitch) and still the same CEL code Im stumped please help
  4. 2006-2012 Eclipse (General 4G)
    Are there any differences between the front license plate brackets on the different years and models for our car? I keep seeing just one eclipse-specific one that's good for 06-08 (through production date 2/22/08) but I have no idea if my car fits in that date (as an 08). To my untrained eye...
  5. 4G Eclipse GT/SE Specific
    I have a 2007 Eclipse GT 3.8 and was told that oil on the K&N filter might foul the intake sensor, is this true? Thanks Jim
  6. Problem Reports
    Hello guys, As the title says, I just think I might have blown my engine. Yesterday's afternoon I went whole red line on 1st gear, didn't noticed I was on manual mode(sportronic trans) I just shifted on to 2nd and nothing happened (at least on that moment), I just kept driving normal. I got...
Top