Mitsubishi Eclipse 4G Forums banner
maf sensor
1-19 of 20 Results
  1. Problem Reports
    So I had a code on my 2006 mitsubishi eclipse gs 2.4 L 4 cylinder. Where it said Catalytic converter warm up efficiency was bad. I was told it could be one of a few things. The MAF sensor (I replaced it, and made no change) the catalytic converter was bad, or that it was the downstream oxygen...
  2. Automotive For Sale/Wanted
    DC Sports Cold Air Intake Pretty self-explanatory. This fits the 4G69 (06-08,5MT). I know there's a difference in the 09+, but I can't remember what's relevant to that. It came off my 06 GS MT. I'm also including the MAF sensor, which to my knowledge still works, as well as a AEM water sock...
  3. 2006-2012 Eclipse (General 4G)
    I bought the Turbo kit from RRM for the Ralliart 2.4l Mivec, what i have is the 2006 Mitsubishi Eclipse 2.4l, 4G69 motor and i am confused as to how the Vacuum lines and piggyback ecu vacuum sensor hose all get hooked up at the air manifold. Can some one either show me a pic or drawing of where...
  4. Problem Reports
    I’m stumped. I got a 2008 Mitsubishi Eclipse GS. When I turn the AC on, the engine hesitates and I lose power. I read the MAF sensor needs to be cleaned but that there was a mention on the cleaner directions not to use on Mitsubishi vehicles. Now, on the Lancer/Evo forum, some posters have used...
  5. 4G Eclipse GS/SE Specific
    Hi All, New problem popped up code P0174 no other codes Things we did prior to this code due to other codes: Replaced exhaust manifold and 4 O2 sensors a few months back as we had a different code indicating precat and O2 problems and live data was showing precat and O2 sensor readings that...
  6. Problem Reports
    Ok so i am a new eclipse own (had the car for 4 days now) and when i purchased it, it had a known idle issue. The car is a 2006 GS with the 2.4 all stock. The car will start and rev to around 2K and fall back down to about 1600. Then it will bounce back and forth from 1600 to 2K. Not a fast...
  7. Problem Reports
    Gutted 3 cats no prob added CAI BIG problems So after I gutted all 3 cats life was great. I got a big hp performance boost. I put a Cai on and now I'm having trouble. I completely took all stock air input out of car. I hooked up just the vacuum tube to cai. And plugged in maf sensor. Car...
  8. 4G Eclipse GT/SE Specific
    Forgive me if this has already been covered in a prior thread - I did check and didn't see it. 2 days ago, I made the mistake of taking my 2006 GT to a local Jiffy-Lube for what was supposed to be a quick oil change. I stood nearby (behind glass window) and watched as they fussed with the...
  9. 4G Eclipse GS/SE Specific
    First off, I'm a long time lurker and searched all over for others with this problem and couldn't find anything. I have a 2007 GS and I just installed a DC sports CAI and now my engine is heating up dangerously hot after a few test drives. the temp gauge will hang just above the middle and...
  10. 4G Eclipse GS/SE Specific
    Before I begin, I did search but could not find anything. I have a 07 eclipse gs MT. I bought a dc sports cai(cai4006) and went to install it on my eclipse. Everything installed perfectly except for the MAF sensor, the holes on the pipe and the holes on the MAF sensor do not line up. Has anyone...
  11. Problem Reports
    Hey there, I have just recently joined and have had a problem going on for about a month and a half. My RPMS tend to drop and pick back up at idle( or at a stop) but goes away and comes back after driving around for a bit. My CEL goes on but turns off before i can get to a shop so they can check...
  12. Problem Reports
    Alright guys I desperately need your help. After replacing my MAF sensor I was getting a couple lean error codes so I reflashed it (uvtune). During the flash it was saying "error code 3" or something similar. At the end of the flash it said "cable disconnected" and then "ecu successfully...
  13. Problem Reports
    Car is running like shit and won't let me go above 4k rpm without the engine braking back at me. OBD-II reads low mass airflow voltage. I'm troubleshooting everything I can before having to replace the MAF sensor. Does anybody know the fuse number linked to it? Or if anyone else has any helpful...
  14. Problem Reports
    This morning after I started the car my engine light was on. Checked Torque lite and it showed code P0305(cylinder5 misfire). Took it to a mechanic and he said my car is pretty new and miles are low. So he just reset the code and told me to come back if it keeps lighting up. Now this afternoon...
  15. Automotive For Sale/Wanted
    my intake was stolen and need to replace maf, any suggestions?
  16. Automotive For Sale/Wanted
    Hey, I'm not a Mitsu owner, but I came across an Injen intake in a car at work that was scrapped. I'm located in canada, but shipping is no problem. Buyer pays of course. Its in great shape, has the maf sensor, couplers and clamps, no filter though. It is Genuine Injen, and I believe this kit...
  17. Problem Reports
    hi im suck with a problem and cant figure it out. 2 weeks ago my car go broken into, among the thing that got stolen was my short ram intake along with the maf sensor umm im short on cash so i bout a cheep cold air intake, just to try something new out, then i realized that the maf sensor went...
  18. Problem Reports
    I have a fujita cai on my 07 gs and it was raining all day while I was driving around town for an hour or two. And the car ran fine the entire time and then the second I got home and put it in park it dropped down to 300-400rpm for a second and then died and the battery, oil, and service engine...
  19. 4G Eclipse GS/SE Specific
    I have a Fujita CAI and the filter has gotten wet before and caused the engine act up so I sat and waited for it to dry once before. But the other day it was raining all day long and I drove around town for an hour or two and the car ran fine, then the second I got home and put it in park it...
1-19 of 20 Results
Top