Mitsubishi Eclipse 4G Forums banner

o2 sensor

  1. Problem Reports
    Hi Need some advice. 2007 2.4l 275K miles I've owned the car since 2010, 33K miles. I've had great luck with this car, no major issues ever, except for the brakes randomly going out on me about 2 years ago-which was fixed with a recall. Not sure if any of this is related. I screwed up...
  2. Problem Reports
    I have a 2009 with the 2.4L that after pulling into the driveway the other night the check engine light came on and it started idling rough as hell. I shut it off and restarted it. It started back up but ran rough as hell, tach was at around 1000rpms but it felt like 150-200, it would finally...
  3. 4G Eclipse GS/SE Specific
    Just got done building my turbo. The last thing I need to do is put a o2 sensor on my downpipe. What do I do with all the o2 sensors? Which o2 sensor goes to the the down pipe? Thanks Sent from my SM-G960U using Tapatalk
  4. Problem Reports
    So I had a code on my 2006 mitsubishi eclipse gs 2.4 L 4 cylinder. Where it said Catalytic converter warm up efficiency was bad. I was told it could be one of a few things. The MAF sensor (I replaced it, and made no change) the catalytic converter was bad, or that it was the downstream oxygen...
  5. 2006-2012 Eclipse (General 4G)
    Can someone give me link to some bosch or other good brand for O2 Sensors. Its for a GT Sent from my iPhone using Tapatalk
  6. Problem Reports
    2007 Eclipse GT. Just recently I've been experiencing frequent (but not always) low engine idle speeds when stopped. RPM's hover just above 0 -- it stalled once, but only once. But sometimes it idles fine. I've noticed that the low idle RPM's seem to coincide with what sounds like the AC...
  7. Problem Reports
    Hello everyone, I own a 2007 Mitsubishi Eclipse GT and I've had the dreaded O2 sensor codes for as long as I can remember. Just the past weekend, I decided to gut out my pre-cats and install O2 spacers for the oxygen sensors (All 4). I was hoping that the codes would finally disappear but sadly...
  8. 2006-2012 Eclipse (General 4G)
    Tried to replace starter this weekend on my 2010 GS 85k miles. When attempting to remove the O2 sensors from the exhaust manifold to get the heat shield off, only one sensor would come out. On the stuck one, i ended up using almost an entire can of PB blaster, a torch, some big leverage bars...
  9. 4G Eclipse GT/SE Specific
    I have n 06 eclipse gt that I just changed the b1s2 o2 sensor and went ok but when trying to start car got nothing--went thru the video to reset ecu but all I get is when I open door and put in key to acc. I get trip area and door emblem on but it flickers and when I go to ON nothing--bad ecu...
  10. Eclipse Performance
    Anyone have any luck with O2 sensor simulators. Need to pass inspection, but don't have the $1200 to dish out for a manifold cat just yet. Looking for a temp fix to get passed.
  11. 2006-2012 Eclipse (General 4G)
    anyone that can give me a link to minicat o2 sensors spacers? for a 2007 Mitsubishi Eclipse GT Sent from my iPhone using Tapatalk
  12. Automotive For Sale/Wanted
    FS: Tanabe strut bar, O2 Sensor, iPod connect, Alpine stereo with head unit I am selling the following: 1) Tanabe front strut bar SOLD 2) OEM oxygen sensor $60 Shipped 3) iPod connect for factory stereo $10 Shipped 4) Alpine stereo + head unit + steering wheel control module + wiring $130...
  13. 2006-2012 Eclipse (General 4G)
    All 4 02 sensors are at the bottom of the car they meet together vs at there separate banks. A shop told me to install factory exhaust manifolds. And I believe rhe headers on this GT are from obx. Any ideas? It has a rough idle to it as well. Sent from my iPhone using Tapatalk
  14. 2006-2012 Eclipse (General 4G)
    Hey guys, I'm replacing my front downstream O2 sensor today, but the clearance I get on the front for the O2 sensor socket is much different from the rear O2 due to the heatshield? Not sure if the heatshield extends all the way to the bottom. I heard people actually using ratchet wrenches to...
  15. 2006-2012 Eclipse (General 4G)
    So I'm planning on gutting my headers soon, however heard that it will fire o2 sensor codes. This is fine however needing to past emissions, would a Tune solve this? Like tweaking the A/F ratio so that it will burn better, or wold they just disable the sensors, because if that is the case I can...
  16. 4G Eclipse GT/SE Specific
    So heres my issue i had bought and replaced my bank1 sensor 1 o2 sensor a while back and it has died on my i guess it keeps throwing stuck lean codes for bank1 sensor 1. So unless i replaced the wrong one idk whats going on. I tried swaping sensor 1 between the banks to see if it would move to...
  17. 2006-2012 Eclipse (General 4G)
    Anyone know if I would run into fueling issues by removing and plugging the rear sensor bungs? or would I just keep the same CEI on the dash?
  18. 2006-2012 Eclipse (General 4G)
    My car displayed the Check Engine Light today and I used an AutoLink scanner to check. I have the P0031 - HO2S Heater Control Circuit Low Bank 1 Sensor 1 message. I was able to locate all four sensors, but I don't know which one is for Bank 1 Sensor 1. Please help me find the correct sensor...
  19. 2006-2012 Eclipse (General 4G)
    So this is wierd i think i may have the same overvolting issue that Neoclod had. The drive into town was fine. On the way home my traction control and loss of traction lights came on the CLE was already on because of my O2 sensor i need to replace. This is what I found. I cleared it thinkin...
  20. 2006-2012 Eclipse (General 4G)
    hi how do I fix the problem with o2 senor power … I keep have this problem .. once in a wild the check engine light will come on and I check it out saying that there not enough power to the o2 sensor help pls ..???
Top