Mitsubishi Eclipse 4G Forums banner

problem

  1. Problem Reports
    When I turn on my AC it makes a rattle sound, it sounds almost like a pebble in there. But I do not know where to look for this problem. The sound aggravates me, and I want to fix it. The AC works perfectly fine though. Does anyone know the cause of this almost ticking/rattling noise.
  2. Problem Reports
    I'll just explain everything and you can straighten me out... 2007 Eclipse 4 cyl auto trans, 215K miles. I'm driving and the car suddenly goes into 3rd gear. D on the dashboard is blinking. I putt putt to my work and turn it off. Later in the day I come out and everything is now fine. Go...
  3. 2006-2012 Eclipse (General 4G)
    Hi guys I’m new member here and I’m trying to figure something out in my car for a week and still no luck.. so I bought a fog lights and I plugged them and I bought a switch & it came with harness as well.. so what I did as it showing in the picture I cut off the old harness because it was too...
  4. 4G Eclipse GS/SE Specific
    I have a 2008 eclipse with the 4cly engine. having what seemed at first to be a starter problem where it would try to turn over and sound like it was shorting out, no smoke or anything I could detect. wiggling the key did not really help. It got progressively worse and at one point now the air...
  5. Interior and Exterior Modifications (Show)
    Hello all, was part of the club 3g forum for about 8 years and just recently upgraded to a 2011 gt 3.8L with all the prem add on's (Rockford, Leather heated seats, HIDs, back wiper, etc) My problem is the headlights are fogged and had this issue on my old 3g eclipse so i just replaced the...
  6. 2006-2012 Eclipse (General 4G)
    The silver button inside the car that releases the E-brake keeps popping out of the handle. So the E-brake won't engage anymore. I have had this problem for a while now and it looks like the thread inside the plastic button has been rubbed out completely so it can't skrew on the E-brake cable...
  7. New Members Forum
    So for a while I had been feeling something that I couldn't quite describe, It felt like it was coming from the front left of the car usually would start too feel it at around 30-35mph an it would stop anywhere between 40-55mph. I first thought it was something to do with wheels/ suspension so I...
  8. Problem Reports
    Hey guys, quick question. I've been having this problem for a while now and can't seem to pinpoint what's causing it. So basically it only happens when I've driven the car for a while and warmed up, or when I'm soft braking at low speeds, like in a parking lot or something, but it doesn't occur...
  9. Driveline
    Hello everyone.... I have my daughters old 2008 Eclipse GS with the four speed automatic transmission. It is throwing OBD codes PO743, PO763, and PO768 These seem to be related to the solenoids in the transmission. I've never worked on an automatic transmission. Anyway it only has Reverse and...
  10. New Members Forum
    Hello my name is Heyshar. I've been a member since last year. I didnt know how this worked so I have never write anything over here. Now I have a problem and I dont know if this is the right forum. But my car is a 08 Mitsubishi Eclipse gt 3.8 M/T. Im having problems trying to find the flywheel...
  11. 2006-2012 Eclipse (General 4G)
    Has anyone ever had a problem with clogged brake hoses?
  12. Audio & Lighting
    Hey guys. So I've soaked up what I can from past threads concerning ECOM and I have the following info to preface this troubleshooting with. 1. I have the stock Rockford Fosgate factory unit, though I have not visually confirmed the amp is stock. 2. I bought the car used and there does seem to...
  13. Problem Reports
    I'm getting a code C1505, saying that the rear left valve is not to factory spec? When I press on brakes it feels spongy, and it doesn't happen all the time. Has anyone had this problem? Will replacing ABS module help or is this something entirely different?
  14. Automotive For Sale/Wanted
    All I have left are these taillights, everything else has been given new homes. They are used, but are not scrached or chipped. They may need resealed, as they had started sweating inside the lens on muggy days, but I am not sure. $50 takes them.
  15. Problem Reports
    Hey guys, so I have no light on the digital dash clock, is this a fuse problem or a bulb problem I need to replace on the digital dash clock itself? Thanks.
  16. Problem Reports
    I've got something going on with my Eclipse 4G, and I can't figure out what it is. I'm trying to avoid taking it to a shop and blowing 500% more money than what the repair is worth on mechanics time and repairing parts that aren't the problem. So I thought I'd ask here first. Here's the deal...
  17. Problem Reports
    Recently bought an '06 GT - didn't try the air until it got hot - no air. Pump was not engaging - all lights were coming on. Found a small brass valve on top of the AC pump that was stuck open. It looks almost like a needle/seat from a carb. Pressure safety shut off? Not sure but I took...
  18. 2006-2012 Eclipse (General 4G)
    C1505 - Dynamic Stability Control Left Rear Valve Malfunction Read more: https://www.autocodes.com/c1505.html This is the code I'm getting. Has anyone ran into this sort of problem?
  19. Wheels, Tires, Brakes and Suspension
    Hi all, 10 years ago when I bought my eclipse (3.8L V6) I had an Eibach lowering springs/kit installed. I just recently broke the rear passenger spring. The mechanic said I'd have to make sure to get the same size replacement spring. The problem is I can't remember the size of the springs...
  20. Problem Reports
    since i bought the car everytime i turned on the ac the car starts to idle rough i dont know what it could possibly be if anyone knows or can assist i will be grateful thank you (checked if this was already posted could not find one)
Top