Mitsubishi Eclipse 4G Forums banner

sensor

  1. 4G Eclipse GS/SE Specific
    Aren't we supposed to get a code when we disconnect the knock sensor? I disconnected mine and have no code even drove around the block. Sent from my SM-G960U using Tapatalk
  2. Problem Reports
    Greetings. On my 2007 GT 6 Speed, I get the TCL, TCL OFF and ABS lights on together. Reading codes from the TCL module shows "Front Left Wheel Speed Sensor". Reading live data while driving shows identical speeds from all four wheels (when driving straight forward). I tried reseating the wheel...
  3. Problem Reports
    I've got something going on with my Eclipse 4G, and I can't figure out what it is. I'm trying to avoid taking it to a shop and blowing 500% more money than what the repair is worth on mechanics time and repairing parts that aren't the problem. So I thought I'd ask here first. Here's the deal...
  4. 2006-2012 Eclipse (General 4G)
    i have checked and searched everywhere before i posted. We seem to can't fix this pesky code.the following is what have been done: checked for vacuum leaks as it has a DC sports air intake and could not see or hear any leaks. cleaned MAF- the only thing odd with that was the rubber o ring is...
  5. 4G Eclipse GS/SE Specific
    Just got done building my turbo. The last thing I need to do is put a o2 sensor on my downpipe. What do I do with all the o2 sensors? Which o2 sensor goes to the the down pipe? Thanks Sent from my SM-G960U using Tapatalk
  6. Problem Reports
    So I had a code on my 2006 mitsubishi eclipse gs 2.4 L 4 cylinder. Where it said Catalytic converter warm up efficiency was bad. I was told it could be one of a few things. The MAF sensor (I replaced it, and made no change) the catalytic converter was bad, or that it was the downstream oxygen...
  7. 2006-2012 Eclipse (General 4G)
    Hey guys, I'm on page 194 of https://tearstone.com/eclipsefsm/2006_PS24S_MMNA_SM_PDF/GR00000400-90.pdf looking at connector A28, which is for the air temp sensor for the A/C, I'm trying to figure out which pin is pin 1 and which is pin 2. Is the little diagram in the bottom left for the...
  8. 2006-2012 Eclipse (General 4G)
    Can someone give me link to some bosch or other good brand for O2 Sensors. Its for a GT Sent from my iPhone using Tapatalk
  9. 2006-2012 Eclipse (General 4G)
    Has anyone had any experience with removing the input and output shaft speed sensor on an automatic transmission? Engine is a 3.8.
  10. Problem Reports
    So that some of you will benefit from my experience. I needed to change my upstream, driver's side oxygen sensor. I went to RockAuto and ordered a Bosch 15582 oxygen sensor. In the description for this part, it says that the wires from the sensor to the plug is 18.1". After removing the old...
  11. Problem Reports
    I recently got the dreaded engine light and got the code read at a local O'reilly's. The code stated P0051 Oxygen sensor heater control circuit low Bank 2 sensor 1. Which sensor is involved? And is it only the sensor that could cause this or something else?
  12. Club4g AutoGuide Forum Support / Help
    How do you unclip the connector on the pressure regulator on top of fuel pump, it's the one with the wire retainer around it?
  13. Problem Reports
    2007 Eclipse GT. Just recently I've been experiencing frequent (but not always) low engine idle speeds when stopped. RPM's hover just above 0 -- it stalled once, but only once. But sometimes it idles fine. I've noticed that the low idle RPM's seem to coincide with what sounds like the AC...
  14. Problem Reports
    Hello everyone, I own a 2007 Mitsubishi Eclipse GT and I've had the dreaded O2 sensor codes for as long as I can remember. Just the past weekend, I decided to gut out my pre-cats and install O2 spacers for the oxygen sensors (All 4). I was hoping that the codes would finally disappear but sadly...
  15. Problem Reports
    07 GT This is a new one for me. Cold start I have been getting a bad misfire and loss of power. The car would sputter down the road until it warmed up and enters closed loop operation. In closed loop it run great with no issues at all. I pulled codes today and have: P0057 heater control b2s2...
  16. 4G Eclipse GT/SE Specific
    I have n 06 eclipse gt that I just changed the b1s2 o2 sensor and went ok but when trying to start car got nothing--went thru the video to reset ecu but all I get is when I open door and put in key to acc. I get trip area and door emblem on but it flickers and when I go to ON nothing--bad ecu...
  17. New Members Forum
    so im new to the group, and not sure if this topic has been covered, please send the thread if so. i bought a 2001 gs 5 speed, for 400 running, w/o dtc codes, had a slight idle prob after warm, and pulling up to a red light car had to be in neutral and the throttle had to be feathered to keep...
  18. Problem Reports
    good morning guys, I'm new to the forum, I'm sorry if this is not the right place to post about a problem I'm having with my car, 2007 Eclipse GS 4 cylinders (2.4) runs great but at times it dies on me I could driving down the road with my foot in the gas pedal and it dies, or I could be in a...
  19. Eclipse Performance
    Anyone have any luck with O2 sensor simulators. Need to pass inspection, but don't have the $1200 to dish out for a manifold cat just yet. Looking for a temp fix to get passed.
Top