Mitsubishi Eclipse 4G Forums banner

spark

  1. 4G Eclipse GT/SE Specific
    So I was driving today on the freeway and I was in second gear to overtake a big semi, but I didn’t realize I had to shift! (stupid me) so the the tach bounced off the limiter and I just hear my exhaust go “pop pop pop” and the car shut off. I coasted into a gas station, tried to start it up...
  2. 4G Eclipse GS/SE Specific
    A while back I changed my spark plugs for the first time and noticed some oil in cylinders #2 and #3. It wasn't an alarming amount and it was mostly up by the top of the plug and not at the bottom, so after a chat with my mechanic friend I decided it wasn't an emergency. I bought the valve cover...
  3. Eclipse Performance
    I'm drenched in confidence today, although that might be baked on sweat because it was 90 degrees outside. I just performed my first modification on my darling Eclipse and fitted her with a cold air intake! This is probably pretty commonplace around these parts, but for me this is only my...
  4. Vendors
    June is a busy month for manufacturer rebates at RockAuto.com! Take advantage of rebates from ACDelco, AutoLine, Auto Meter, Fab Fours, Holstein Parts and KYB that are valid through June 30th. Save even more on RockAuto's reliably low priced Fuel Injectors, Distributors, Truck & Jeep Bumpers...
  5. Problem Reports
    I've got something going on with my Eclipse 4G, and I can't figure out what it is. I'm trying to avoid taking it to a shop and blowing 500% more money than what the repair is worth on mechanics time and repairing parts that aren't the problem. So I thought I'd ask here first. Here's the deal...
  6. 2006-2012 Eclipse (General 4G)
    Upon removing my cylinder head to replace a blown head gasket, I was cleaning up the mating surfaces on the head and as I spun it around to get to each surface, these fell out. Two of them fell onto the ground and I was not able to tell exactly where they came from and one was loose inside one...
  7. New Members Forum
    Hello there! I'm AJ, out of Maryland, US. Just joined the club with a 2009 Eclipse Spyder GS. I've always had a crush on the Eclipse since I was younger and Fast and the Furious came out. The body style was so sleek and smooth looking. I was elated to see that this 4G was the only car in my...
  8. 4G Eclipse GS/SE Specific
    So here's the lowdown: I have changed the camshaft sensor/crankshaft sensor, thermostat, coils, spark plugs, coolant, cleaned MAF, cleaned throttle body, put new clutch and throwout bearing. Oil is topped off good and no real leaks. The car drives real good for about fifteen minutes and then...
  9. New Members Forum
    Hey yall, first post, i came across the site after purchasing an 04 galant 4g69 engine that needed a timing belt overhaul. Losts of noise and chatter. Got the car for $600 and drove a little. the car was in time when I purchased it and before I began to work on it. I have so far taken off the...
  10. 2006-2012 Eclipse (General 4G)
    Anyone have an idea as to what it would be, Ill h driving normally and the car tends to jerk a bit. Possible Fuel injectors? Spark Plugs? Let me know thanks!! Sent from my iPhone using Tapatalk
  11. Problem Reports
    Hi everyone, hope you all are doing well. So my 07 GT (6-speed) is experiencing two misfire codes. At first, it was P0304, so I checked the front bank of spark plugs and found the plugs and boots to be covered in oil. I changed the valve cover gasket and tube seals on those, and the code went...
  12. 2006-2012 Eclipse (General 4G)
    I searched on a few things and didn't see a discussion so I'm going to put my questions here ... My car: 2007 Spyder GT ... 97K auto , prior owner had just changed out the valve cover gaskets and installed a new top... I just had the timing belt (Dayco Premium), water pump and spark plugs...
  13. New Members Forum
    so im new to the group, and not sure if this topic has been covered, please send the thread if so. i bought a 2001 gs 5 speed, for 400 running, w/o dtc codes, had a slight idle prob after warm, and pulling up to a red light car had to be in neutral and the throttle had to be feathered to keep...
  14. Problem Reports
    Hopefully someone has an answer for my really obscure problem I've been troubleshooting. So I just did an engine swap, and now when I turn the key to "On", power is alright. The ECU is getting 12v, ECU grounds are good, body grounds are good, trans ground is good. However, when I turn it to...
  15. Vendors
    Summer has begun, which makes it a great time to catch up on vehicle maintenance! And to make now an even better time to inspect and replace your vehicles' worn out parts, over 30,000 of our already low, Wholesaler Closeout priced parts have been discounted another 50-70%! Find Air Filters...
  16. Member's Rides
    The Eclipse has been my dream car since I first tricked it out on Need for Speed :naughty:. I finally went ahead and bought my 2010 Eclipse GS-Sport this past December; I've been working on it non-stop since then. It's gotten to the point where I think it's dope enough for me to start a build...
  17. 4G Eclipse GT/SE Specific
    Changing timing belt on my 09 eclipse GT. Marks all lined up first time but moved when I loosened crank pulley bolt,when I try to line them up now they all go past marks,2 teeth on each cam & past TDC on pulley.I backed the pulley & all marks line up.I didn't take spark plugs out & im thinking...
  18. 2006-2012 Eclipse (General 4G)
    2006 Mitsubishi Eclipse GS/AUTO I originally bought this baby in February 2018 at around 178,000 miles on odometer (yes I know that’s quite a lot) but at that time I was car-less and needed transportation to work and school lol so I purchased her for $3500 and have been working on getting...
  19. 2006-2012 Eclipse (General 4G)
    What's up Eclipse homies? I bought my 2010 Mitsubishi Eclipse GS-Sport this past winter. Now that the midwest is finally starting to warm up, I'm going to spend the next couple months modding the hell out of it. So far, I've put new Perelli tires & black rims on it, plasti-dipped all of the...
  20. Problem Reports
    Hi, I go by Slip thanks ahead of time for this silly post. Okay lets get started, I'm working on my 06 G4 with the 4G69 motor the timing belt broke and I replaced it. Now with this being said yes every 2 rotations of the crank the cam and crank line up. So now I have a no spark issue. I go in...
Top