Mitsubishi Eclipse 4G Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
Hey everyone, I joined a few months ago and this forum has been the BIGGEST help for me deciding what to do with my car.

My name is Austin and I got my 4g as a graduation present right at the end of my senior year which was almost 2 years ago now. Life is beginning to pick up a little and I finally have the time and money to do little odds and ends to my car that really make it my own.

She has:

Injen CAI
Apexi N1 style muffler (cheapie from carid that actually sounds really nice)
TB bypass
RRE Pulley
Ksport Kontrol Pro coils

XXR 527 (cliché I know) 18X8.75 +20
Those are wrapped in 225/40 Continentals

Tinted tails (autozone special similar to plastidip)

I also plastidip pend the panel underneath the spoiler (looks badass on the grey color of the car IMO)

Diode Dynamics RGB Multicolor LED fogs

Hopefully I'll be posting more often, eventually you guys will see some professional photos as I've been working with some people.




Sent from my iPhone using Tapatalk
 

·
Premium Member
Joined
·
990 Posts
Welcome Austin! I'm glad we can be of such great help to you and your build, we're always here to help further if you need it!

I actually don't mind the rims, I think they look pretty decent! What other mods do you have in store?
 

·
Registered
Joined
·
6 Posts
Discussion Starter #4
Nothing else too major in the near future as I'm sort of in between jobs relying on money I've saved up.

I won a giveaway recently with a shop that does really good vinyl work. So I'm going to have a carbon fiber wrap on my hood. But other than that nothing else for a while.
And yes it's a five speed, which happens to have a worn out input shaft (I think)


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
1,702 Posts
Good, cuz if it were an auto we'd have to permaban you.

Lol, I kid. Lots of auto 4Gs around, most with good owners. What are the symptoms of your transmission? Funny noise? Grinding? Difficulty engaging a gear?
 

·
Registered
Joined
·
6 Posts
Discussion Starter #6
It starts making a loud whining noise whenever I'm going around 30mph and it gets louder and higher pitched as I gain speed. It stops for a second whenever I shift. It's been like that for quite a while, it doesn't seem to have lost any performance or anything and I haven't the time or money to look into it.


Sent from my iPhone using Tapatalk
 
1 - 6 of 6 Posts
Top