Mitsubishi Eclipse 4G Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1 (Edited)
I have owned it the last 10 years. Have kept up with oil changes & maintenance 104K on odo . Two new tires, dash always covered. Bone Stock. Starts, runs, shifts fine no issues . Makes a bearing noise when clutch pedal is out (engaged) goes away when I push down on the pedal. Been told might be "input bearing".

I just drove it 200 miles; noise has not gotten any worse. Located in Santa Barbara, California. Have loved the car; being I am pushing 60 years old gonna
treat myself to a Tesla; hope some one has ability or interest to repair or part out (all good body panels accident free). Open to offers.
 

Attachments

·
Basically Stock
2009 GS Turbo. 2006+2007 GT
Joined
·
6,054 Posts
That'll be the clutch release bearing most likely, especially if it's chirping. It is supposed to get changed with a new clutch every time, sometimes they go early, other times they aren't replaced to save a few bucks. I had one last 100k miles, one last 3k miles.

Good luck with the sale
 

·
Registered
Joined
·
6 Posts
Discussion Starter #3
>>>That'll be the clutch release bearing
Umm are you sure ? Noise is when pedal is up, and in neutral ( engaged like the drive train and trans are married). When I depress the pedal it goes away. Everything I know and read says it's the "transmission input" bearing.

Not just service the clutch and new throw-out (pilot) bearing.

Anyone ???
 
1 - 4 of 4 Posts
Top