Mitsubishi Eclipse 4G Forums banner

1 - 11 of 11 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
good morning guys, I'm new to the forum, I'm sorry if this is not the right place to post about a problem I'm having with my car,
2007 Eclipse GS 4 cylinders (2.4) runs great but at times it dies on me I could driving down the road with my foot in the gas pedal and it dies, or I could be in a stop light and suddenly dies this is being going on for over a month now, after some time and it's always different it could be just a couple minutes to up to 15 minutes and it starts again car does not have the muffler,check engine light sometimes comes up for a few days then it disappears I took it to autozone and it read something about the oxygen sensor and heating on the exhaust system I'm not really sure exactly what it read it's been a while and I threw the paper away

I need suggestions please
 

·
Moderator
Joined
·
2,690 Posts
That's not a normal O2 sensor failure.

Find what the actual code is. O2 sensors readings shouldn't have enough fueling control to actually stall the engine.
Yeah I just gave that advise because he mentioned exhaust heaters, I thought he meant a code for the O2 sensor heater circuit
 

·
Super Moderator
Joined
·
341 Posts
I never had an issue with my car literally dying with my cat clogged, but does it seems like it dies instantly, or does it chug? If it dies instantly, I would pop the hood and start wiggling wires around at the plugs to see how the car reacts (Wiring harness wires). I had an issue where a sensor in my car had bad wiring from the wire to the plug and I figured it out by literally wiggling the wiring at the base of the plug. It's a good idea to do this, mostly the ones around the timing belt and the alternator is where my problem was.
 

·
Registered
Joined
·
21 Posts
Same thing has happened to me before. The car would just die as I'm driving but luckily I have a manual so I would pop start it right away as my car is moving. It was from a loose battery terminal that would move around as I'm driving and come off/loose. I can suggest u check your terminals and tighten them.
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #9 ·
hey guys sorry I haven't reply back to you, I'm still having the same problems with my car I don't drive it any more kinda been driving the wife's car whenever I can lol, but any way back to the my car, to answer some of your questions, when the car is running nothing else seems to be off everything is normal, I could have my foot in the gas pedal and car would just die on me, the times that it dies is at random I can be driving the car for 5 minutes and it dies or 2 hours and it dies and when that happens I sometimes have to wait up to 30 minutes for it to start

the battery has enough juice to start the car be cause when the car dies and I try to start it back up it tries to start you can just hear the engine not sucking up enough fuel
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #10 ·
I used to think that's what it was I even change connectors and car was running without problems for like a weeks then it started doing the same but yeah it was really bad with the old connectors that I actually thought that was the problem but since I changed the connectors it's not as bad but I still have the same problem,

another question I've notice there's a 120 amp fuse that comes from the alternator do you guys know if I have to have it there? cause I was thinking may be that could be the problem too
 
1 - 11 of 11 Posts
Top