Mitsubishi Eclipse 4G Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
12 Posts
Discussion Starter #1
I can start my car just fine but it doesn't sound right and smoke spews from my AC compressor and it keeps stalling out. It only started after I got off work and everything has been running perfectly fine until now and I need to fix it asap. Any suggestions on what to fix first?
 

·
Moderator
Joined
·
2,510 Posts
I can start my car just fine but it doesn't sound right and smoke spews from my AC compressor and it keeps stalling out. It only started after I got off work and everything has been running perfectly fine until now and I need to fix it asap. Any suggestions on what to fix first?
Your AC clutch is stuck on?
Turn off the AC switch and then have someone start the car while you stare at the ac compressor pulley, you see the end with the 3 bolts? That should not spin with the outside of the pulley if the AC is commanded to be off
 

·
Registered
Joined
·
12 Posts
Discussion Starter #3
Its been throwing codes on the AC module but I can't even turn the pulley. I ended up taking it off after snapping a bolt on it😥 but I'm just gonna replace the whole compressor. Is it possible to reroute my belt?
 

·
Moderator
Joined
·
2,510 Posts
Its been throwing codes on the AC module but I can't even turn the pulley. I ended up taking it off after snapping a bolt on it😥 but I'm just gonna replace the whole compressor. Is it possible to reroute my belt?
Sure it’s possible! Need a shorter belt, not too sure just how much shorter tho
What kind of AC module codes r u throwing?
What’s your AC module live data show? Clutch on and relays and such?
 
1 - 5 of 5 Posts
Top