Mitsubishi Eclipse 4G Forums banner

21 - 40 of 52 Posts

·
Registered
Joined
·
707 Posts
I was going to use bolts insted of studs and nuts but you have a high risk of pulling the threads using bolts. I know my bigblock i rebuilt in high school was all bolts holding the manifold on vs having studs and nuts.

Sent from my VS995 using Tapatalk
 

·
Registered
Joined
·
142 Posts
Discussion Starter #24
Ohh alright bolts instead of studs
Yeah I was wondering about that but figured that wouldnt be recommended lol I really wish I could take a stuff out of the head and bring it in the store but I mean I would have to take my manifold off for that and this is my daily driver so only way I get to autozone to get things is with this car

RIP


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
142 Posts
Discussion Starter #26
And can I use copper gasket sealant on my two new manifold gaskets? Is that the ideal thing to use? As well as cleaning out the surface and cylinder head ports with carb cleaner?


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
707 Posts
Ohh alright bolts instead of studs
Yeah I was wondering about that but figured that wouldnt be recommended lol I really wish I could take a stuff out of the head and bring it in the store but I mean I would have to take my manifold off for that and this is my daily driver so only way I get to autozone to get things is with this car

RIP


Sent from my iPhone using Tapatalk
I know all about that. Mine is my daily too. Also i was wrong yes you do have only 6 not 8. So if you wanted to do all 6 you would need 2 packs and you would have some spares. I needed 3 packs to cover all 14 of mine. Also here are the torque specs just ao you have them for the nuts.



Sent from my VS995 using Tapatalk
 

·
Registered
Joined
·
707 Posts
And can I use copper gasket sealant on my two new manifold gaskets? Is that the ideal thing to use? As well as cleaning out the surface and cylinder head ports with carb cleaner?


Sent from my iPhone using Tapatalk
That could be where i have an exhaust leak...... I dont remember ever putting any sealent on.... I used breakclean to clean everything. But carb cleaner should work.

Sent from my VS995 using Tapatalk
 

·
Registered
Joined
·
142 Posts
Discussion Starter #29
Yeah 6 lmao I’m mad it only comes with 5 they only had one pack ugh! Oh well...... thanks so much bro I found pb blaster but no copper gasket or carb cleaner


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
142 Posts
Discussion Starter #31
Finally picked up my package now just waiting for my CAI so I can install everything at once and see the night and day difference haha!



Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
707 Posts
Finally picked up my package now just waiting for my CAI so I can install everything at once and see the night and day difference haha!



Sent from my iPhone using Tapatalk
So confused on that exhaust manifold gasket what's with the random like from shaped one at the end? Needless to say I don't have a 4-cylinder so I have no clue

Sent from my VS995 using Tapatalk
 

·
Registered
Joined
·
142 Posts
Discussion Starter #33
So confused on that exhaust manifold gasket what's with the random like from shaped one at the end? Needless to say I don't have a 4-cylinder so I have no clue

Sent from my VS995 using Tapatalk


Lmao the big long gasket you wondering why it looks like that at the end?? And oh yeah you got the “sportier” one


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
281 Posts
I just dont understand what the circle part acctualy does why not have all 4 match the tubes.



Sent from my VS995 using Tapatalk


That is for the EGR passage from the exhaust 4th cylinder thru the head to the EGR valve in the Intake manifold.


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
142 Posts
Discussion Starter #37
These nuts don’t go past the first couple threads almost like it’s self locking



Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
142 Posts
Discussion Starter #38
Seems like the threading and everything is the same on the studs but these nuts aren’t going on all the way



Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
707 Posts
Take a new stud and hold it up to the ild stud and see if the peaks and valleys match up to make sure its the right threads

Sent from my VS995 using Tapatalk
 

·
Registered
Joined
·
707 Posts
So it is most likely the rust has thrown the tollerances off. Do the nuts screw down on the new studs

Sent from my VS995 using Tapatalk
 
21 - 40 of 52 Posts
Top