Mitsubishi Eclipse 4G Forums banner

1 - 1 of 1 Posts

·
Registered
Joined
·
25 Posts
Discussion Starter · #1 ·
This is kinda long, but please take the time to read it because I would really appreciate it. So about 2-3 weeks ago, I thought I hydrolocked my engine because I accidentally drove through a deep puddle after rain, and as soon as I drove through it, my engine seized and refused to turn over. All that was heard was a loud “click” and that was that. We pushed the car into a parking lot until we figured out what to do. The next day, the engine hesistated, but after a few tries, it turned over and started with a bunch of white smoke coming out the exhaust. After that I took apart the intake, cleaned it, the throttle body, fresh oil, etc and everything was good as gold. Now 2 nights ago, I was messing around with my girlfriend, and launched really hard from a stop sign. Talking, dump clutch, redline 1st, shift hard into 2nd. As soon as I did that, the car seemed to just bog down and die. I tried restarting it, it turned over once, and it sounded real angry, like a monster (3 inch straight pipe, stock manifolds) and right when it did that, died again. I tried to turn it over, and no luck. All that happened was that same “click” from when I thought i hydrolocked it a few week prior. Did a long ecu reset, nothing. Even tried jump starting it to see if maybe it was the battery, nothing. What I did notice though is whenever I tried to turn it over, the positive battery terminal would get really hot to the touch, accompanied by a burning type smell, along with the click. After that I just gave up and let it be, so now I’m coming to you fellow eclipse drivers for help, please and thanks
 
1 - 1 of 1 Posts
Top