Mitsubishi Eclipse 4G Forums banner

1 - 8 of 8 Posts

·
Registered
Joined
·
22 Posts
Discussion Starter · #1 ·
The other day I went to start my eclipse up and it wasn't turning over only cranking so I checked the battery alternator and starter and everything checked out then I went to check the fuel pump and found out that the fuel pump wasn't receiving and power does anyone know what was cause the fuel pump to stop getting power and if so how do you fix it? :(
 

·
tUNED.
Joined
·
4,566 Posts
relay ?? wiring?? computer ?? sounds like it is just an electrical issue with voltage going to the pump
 

·
tUNED.
Joined
·
4,566 Posts
i think the relay would b at the pump
 

·
Registered
Joined
·
5,034 Posts
Look in the box under the hood. There are 2 relay boxes next to the battery. Under the cover is the guide to what the relays are. Could just be a bad pump...pop of the rear seat, there's like 4 screws to the cover then 10 bolts to pull the pump assembly out.
 

·
Registered
Joined
·
1 Posts
The other day I went to start my eclipse up and it wasn't turning over only cranking so I checked the battery alternator and starter and everything checked out then I went to check the fuel pump and found out that the fuel pump wasn't receiving and power does anyone know what was cause the fuel pump to stop getting power and if so how do you fix it? :(
For anyone looking for the fuel pump relay it's under the dash by the hood release there are 2 fuel pump relays in the 4g there's also a fuse for them as well
 
1 - 8 of 8 Posts
Top