Mitsubishi Eclipse 4G Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
13 Posts
Discussion Starter #1
May I get some opinions or experience on this issue. It's been smelling like something is burning pretty bad. When the vent is on its almost unbearable, when off, it still seals through.
My mechanic seems to think it's a valve cover gasket that's blown, but hasn't actually been under the hood yet. Would be be a safe idea to just have that replaced anyway?

I'll be giving him the car next week to work on and want to make sure I'm properly taking every precaution necessary as I am in love with this car haha.

The burning happened after my first round of bolt ones a few months ago so I don't think it's grease or oil burning off parts not wiped off.

I have a set of RRE shorties that are ceramic coated. Down to a Magnaflow exhaust.
I have an aftermarket CAI. It is also tuned by hackish. Recently (about a month ago) I also got a new power steering pump because there was a leak.

I scrolled a few down burning smells, but everything either seems a decade old or about tires or clutches. So I figured I was okay to ask away.
Any advice on where to start?
 

·
Registered
Joined
·
1 Posts
I bought an used 09 4G -2.4 GS last week. Yesterday I felt the same smell kind of burning rubber, plastic or something after I make a ride 100km distance. First I am afraid if something really catching fire inside or what. . I checked radiator coolant next day morning mixed with some oil, pink or rose colour with milky white grease surrounded the radiator mouth. I check with my mechanic. He told me Transmission oil cooler has been changed by previous owner but not in good condition, and because of it CVT Trans oil mixing with radiator coolant. I have to find the parts now. after changing parts I need to flush Trans Oil & Radiator Coolant 3 or 4 times. I hope this process can fix my burning smell issue and long life for my CVT and 2.4 reliable mechine.
 

·
Moderator
Joined
·
2,137 Posts
I bought an used 09 4G -2.4 GS last week. Yesterday I felt the same smell kind of burning rubber, plastic or something after I make a ride 100km distance. First I am afraid if something really catching fire inside or what. . I checked radiator coolant next day morning mixed with some oil, pink or rose colour with milky white grease surrounded the radiator mouth. I check with my mechanic. He told me Transmission oil cooler has been changed by previous owner but not in good condition, and because of it CVT Trans oil mixing with radiator coolant. I have to find the parts now. after changing parts I need to flush Trans Oil & Radiator Coolant 3 or 4 times. I hope this process can fix my burning smell issue and long life for my CVT and 2.4 reliable mechine.
It is not a CVT

do NOT use CVT fluid in the trans

use Castrol Import, Valvoline MaxLife, or any Chrysler ATF+4 fluid

it’s easy to change, there’s a drain plug in the back right corner of the trans by the driver side wheel

do not drive it again until you fix that mixing issue, it’s damaging the trans
 
1 - 4 of 4 Posts
Top