Mitsubishi Eclipse 4G Forums banner
21 - 29 of 29 Posts

·
Registered
Joined
·
44 Posts
Update for

Concern: Brake pedal feel is different at times (soft -> hard -> soft), may be accompanied by a squeak.
Cause:
-Valves in ABS hydraulic unit failing, causing intermittent internal leaks/restrictions causing varying brake pedal feel
-Leaking (internally or externally) master cylinder (causes soft/spongy brake pedal)
Correction:
-If hydraulic unit is causing issue (squeak and differentiating pedal feel), DO NOT REPLACE ON YOUR OWN. There is a special bleeding technique used to bleed air out of the hydraulic unit. Leave this one to the certified trained.


--------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
Mitsubishi
Campaign # NHTSA Recall
Number Recall Date Recall Description Repair Description Safety Risk Description Status


SR-15-004 15V337 May 22, 2015 IN THE ABS HYDRAULIC UNIT FOR THE AFFECTED VEHICLES, POTENTIAL CORROSION MAY OCCUR OVER TIME DUE TO A REACTION BETWEEN THE BRAKE FLUID AND THE SURFACE TREATMENT OF THE INTERNAL VALVES. IF THIS OCCURS AND THE ABS HYDRAULIC UNIT IS ACTIVATED, ONE OR MORE OF THE VALVES MAY SEIZE AT SOME POSITION. THE ABS HYDRAULIC UNIT WILL BE FLUSHED AND CLEANED USING HIGH QUALITY GRADE BRAKE FLUID (DOT 4). DURING FLUSHING AND CLEANING OF THE ABS HYDRAULIC UNIT, IF INSIDE VALVE MOVEMENT IS DETERMINED TO BE POOR, THE ABS HYDRAULIC UNIT WILL BE REPLACED WITH A NEW ONE. THESE REPAIRS WILL PERFORMED FREE OF CHARGE. IF ONE OR MORE OF THE VALVES WERE TO SEIZE, THE BRAKE PEDAL STROKE WILL INCREASE AND BRAKING PERFORMANCE MAY BE REDUCED, POTENTIALLY INCREASING THE RISK OF CRASH. REPAIR NOT YET AVAILABLE

--------------------------------------------------------------------------------------------------------------------------------------------------------------------------------


Symptoms once ABS has been engaged "Slamming on brakes" the pedal is spongy "it has lots of travel" before the brakes will engage to slow down the car. Also when you release the brake pedal it makes a noise that sounds like a cat or a whining noise as the pedal travels back up to its normal resting or "Home" position.

I have this issue on two of my G4s now.

06 that my daughter was driving and I did not know had developed.
07 had to slam on brakes Friday now this car is effected also.

~Viller
 

·
Registered
Joined
·
44 Posts
FlyinRyan,

You can try autozone or pepboys to read and reset the code for free :)

~Viller

Yup, I know I messed up after coming here to read about what happened. I'll definitely be disconnecting the battery when working on my car in the future. I was just hoping for a solution to what has already happened cheaper than the ~$100 the dealer wants.
 

·
Senior Member
Joined
·
4,111 Posts
FlyinRyan,

You can try autozone or pepboys to read and reset the code for free :)

~Viller
The SRS Light can not be reset by an auto parts store.

By Federal Law the SRS system must be checked, verified,
and re-certified by a certified mechanic before the SRS Light
can be reset. So that means a trip to the dealership, or
certified body shop that can work on SRS equipment.
 

·
Registered
Joined
·
5 Posts
Damn, that is a LOOOOOOOOOOOONG list. Do you know if some of these problems (aside of the condenser) have been addressed in the newer models?
 

·
Registered
Joined
·
14 Posts
I like this thread and has answered atleast 2 of my questions. Does anyone know why I may be getting a suction sound from the back part ofy motor i.e. near the intake manifold. It's been happening for a while now and I don't see too much of a performance issue so I've just kind of put it off until now. I've taken the throttle body off and cleaned it, checked for gaps., and no problem there. The only thing I could think is maybe a vaccum line?? Anone else had this problem??
 

·
Registered
Joined
·
138 Posts
I've been seeing a lot of people with issues with their rear view mirror. Specifically with auto-dimming with map lights (sunroof).

Has anyone found a fix for this? I've replaced it once already and from what I've discovered is that it's an internal circuitry issue of the RVM.
 

·
Registered
Joined
·
2 Posts
6g75 problems...

Hello I have a problem with my 6g75.

3 times I faced problems with bearings.
I`ve read that the problem is related with center main bearing bolts.

Someone can help me indicating which bolts I have to buy and from which store?

Best regards,

Mauro
 

·
Registered
Joined
·
23 Posts

·
Registered
Joined
·
23 Posts
21 - 29 of 29 Posts
Top