Mitsubishi Eclipse 4G Forums banner
1 - 4 of 4 Posts

·
Premium Member
Joined
·
388 Posts
Discussion Starter · #1 ·
My secondary fan has been running really loud, and I've noticed my temp gauge up to halfway point. Dealer says the fans are fine, the radiator orifices clogged. I could run a reverse flush, but odds aren't great it will do the fix. Has anyone tried Mr.Bishi's new aluminum radiators? If I went that route I'd want the fan assembly as well, but seems like a very critical and costly gamble on a brand new hand welded part. Anyone installed one in a GT yet? Any significant reason to do this over OEM radiator?
 

·
Registered
Joined
·
150 Posts
First, Mr. Bishi may not be able to get you a rad atm for personal reasons.

Second I’ve read some where someone has mentioned the GT doesnt‘t move air well through the engine bay (i think i read that somewhere on the site). But i guess it depends on your use? Track/auto cross use would make sense. Otherwise an OEM replacement makes sense to me.
 

·
Premium Member
Joined
·
388 Posts
Discussion Starter · #3 ·
First, Mr. Bishi may not be able to get you a rad atm for personal reasons.

Second I’ve read some where someone has mentioned the GT doesnt‘t move air well through the engine bay (i think i read that somewhere on the site). But i guess it depends on your use? Track/auto cross use would make sense. Otherwise an OEM replacement makes sense to me.
Cool, thank you, kinda what I figured but thought I'd throw it out there in case the new radiators were getting out there. I do mix in 2-3 track days annually, but never had issue w/ the OE radiator before. Mostly wanted to throw support to Mr.Bishi, hope he's well and up and running again soon!
 
  • Like
Reactions: InheritedGT
1 - 4 of 4 Posts
Top