Mitsubishi Eclipse 4G Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
58 Posts
Discussion Starter #1 (Edited)
Hi folks, my name is Paul and I’ve recently inherited a 4G Eclipse.

The details:
2006 Eclipse GT 6 speed with about 110k km (about 68k miles).
Typhoon K&N intake.
Some kind of aftermarket headlights (they’re bright and seem to work well but are not completely wired up, project for another time).
Some kind of aftermarket brake set up. The front rotors are slotted and cross drilled, rear are slotted. Not sure about the callipers, they don’t say anything on them. The front are 2 piston, not sure if that’s and OEM design? They’re red. So, there’s that.
Super shiny 18” chrome rims that I dislike.

https://www.club4g.org/board/member...629-f0e1d9b8-4467-4502-9fc5-b52bac2d34db.jpeg

After a little reading on the site, I discovered the 6G75 to be an interference engine. So I scoured the the little service records I had, the timing cover, called a local dealer and asked about service records (interestingly they admitted that not until recently they didn’t keep very good records) and generally did what I could to find out if it had ever been changed. Couldn’t find anything.

So it has a new timing belt, tensioner, idler pulley, water pump and seal and coolant.

I randomly met an admin on a FaceBook Canadian 4G Eclipse club group page. I don’t know his handle, so I’ll leave that for him. But he did provide some other insights and suggestions about the platform, ie oil pump failures and getting an oil pressure gauge and looking around for a tune. Both seem like interesting ideas that I’ll be searching the site about.

Yes my location is Canada, to be more specific, SE Ontario, in Kingston. If you’re local, see me around, stop me. I’m usually always down to shoot the S about cars, motorcycles, boats, planes, racing etc etc.

I guess plans for the car are to daily it/weekend spirited driving. Maybe some light bolt ons. My brother and I are thinking about doing a little auto x starting in the spring time, so any thoughts or experiences people have had are welcomed. I realize it’s heavy and auto x is tough on tires etc. Some solutions people have come with would be welcomed. We were thinking about snatching up cheap used tires off market place and thrash them....

A little more about me, I also have an 86 Harley Sportster that’s sort of a restomod/headache and an 06 Yamaha XT225. My dad was a heavy equipment mechanic so I’ve been around tools and fixing stuff my whole life and I’ve gotten pretty good at breaking stuff too. I do most of my own maintenance when possible or until I break it. Or I break the tool, whichever comes first.

I’ve spent about 30-40 mins reading through a....extensive “new member please read” posts... So I hope I’ve covered everything...?

Thanks for the add. There seems to be a lot really great information available.
 

·
Registered
Joined
·
58 Posts
Discussion Starter #3
It was me you ran into. I'm the only admin around anymore unfortunately.

It's too bad there's a lake and Toronto between us
Lots of good driving in between!
 
1 - 4 of 4 Posts
Top