Mitsubishi Eclipse 4G Forums banner
1 - 8 of 8 Posts

·
Registered
Joined
·
34 Posts
Discussion Starter · #1 ·
Hello everyone, First post here!. I just acquired a UV Blue 2006 Eclipse gs 5 speed last week. I was doing some general maintenance including an oil change, air filter, cleaning up the interior etc. I also disconnected the battery terminals as they were extremely corroded so I cleaned them off. The car came installed with a Pioneer AVH-p2400BT touch screen head unit. Now, all speakers were working fine prior to the disconnection of the battery terminals. Ever since then, sound only comes out of the "sub" (correct me if i'm wrong) behind the drivers seat, no sound out of the doors. Does not matter whether I switch to radio, aux, cd etc. Same problem. Any ideas as to where I should start looking? I feel like the radio has gone into some sort of default mode, but I don't know how to get it back out. I've since tried to find a manual of a similar head unit to see if theres anything there but i'm a bit stumped, i've never had a touch screen deck before. Any ideas? Thanks a million!
 

·
Premium Member
Joined
·
423 Posts
If the sub works, but the door speakers don't, you likely have a loose connection somewhere. The sub and door speakers are both powered from the factory amp under the glovebox. If the sub works, and the speakers don't it's probably a connection issue, rather than a much larger issue. I'd just check the connections, starting behind the radio faceplate, and then in to the door.
 

·
Registered
Joined
·
34 Posts
Discussion Starter · #4 ·
Thanks for the replies. I just find it really odd that they were working before the battery disconnect, and then all of a sudden stopped working. Well, gotta start looking somewhere. I'll post the solution once i actually find time to start snoopin around to find the issue. Thanks!
 

·
Registered
Joined
·
34 Posts
Discussion Starter · #5 ·
If the sub works, but the door speakers don't, you likely have a loose connection somewhere. The sub and door speakers are both powered from the factory amp under the glovebox. If the sub works, and the speakers don't it's probably a connection issue, rather than a much larger issue. I'd just check the connections, starting behind the radio faceplate, and then in to the door.
Sorry my mistake, it turns out the only speakers actually working are the backseat speakers. Both sides work. So the front door speakers and subwoofer in the back trunk are not working. Does this change things a bit with regards to finding the problem?
 

·
Registered
Joined
·
2 Posts
I'm having the same issue actually, from what I've read, the amplifier powers both the front door speakers and the subwoofer. I'm thinking it might be a grounding issue, but I'm not 100% on that one.
 

·
Premium Member
Joined
·
423 Posts
Ah-hah. Are you certain they worked before? Or did you just think they worked before? I find it hard to believe that you all of a sudden have a grounding issue. If it was grounded fine before, it'd be pretty hard to mess up the ground that has worked for 10 years. When I first bought my car, there was a shitty Walmart deck installed, and it sounded like everything worked. Then I zoned in and found out that, in fact, the sub and door speakers didn't work. There is a special adapter you need for the factory systems to work with an aftermarket radio. I'd wager you don't have that. So, there are a few options. You can buy the $100 adapter, or you can bypass the amp and run everything separately. It sound's difficult, but it's not really all that bad. It's really easy to pull out the radio face plate. Just pull out that whole center thing, and reach around and unplug your flashers button. Then you can see if you have the Mito-01 adapter. Get back to me when you find it out!
 

·
Registered
Joined
·
34 Posts
Discussion Starter · #8 ·
Well, i haven't had time to pull out the head unit yet, but as a mini update, my front speakers and subwoofer in the trunk randomly started working again. Weird. I'm still going to pull the hu soon and see whats up
 
1 - 8 of 8 Posts
Top