Mitsubishi Eclipse 4G Forums banner

1 - 3 of 3 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Hello,

Every one on the forum am new here this is my first post and i wish it wan't a problem with my car but maybe some can help me.

I got a 2007 mitsubishi eclipse GS so Last night i was driving home when i can upon my exit off the high way i speed up and took the exit with high speed for fun. i know notice that my oil light come quick for about less then 2 sec. when i got home and park i open the hood to check my oil dip stick and i didn't see any no oil on it. It was middle of the night so i couldn't check under the car. This morning i went out check my car once aging i check the oil dip stick no oil on it. so i went to auto part to buy some oil so i full up wiht oil i drove around. Got home and i check the dip stick it seem i lost some oil. I check under the car i don't see no oil puddle or i don't smell no burning oil or no white smoke coming out of my muffler.

I'm debating if my Oil Pan Gasket Set that need to replace or some thing else is burning up my oil. I hope is not my piston ring but i will super screw

dose any one had this issue or has other idea what could be if there other post like this please link it in the comment so i can check it out

Thank you for time reading my post
 

·
Registered
Joined
·
1,574 Posts
Hello
Welcome to the club!

I had a similar thing happen to me. I went around a corner and the light came on for a min... After further inspection, turns out my oil filter had a tiny pin hole in it... right on the bottom of it... I was thinking a rock must have hit it just right...or it was defective...

It may not be your issue, but wont hurt to go take a look.


What makes you think oil pan gasket?
 

·
member
Joined
·
226 Posts
Spark plugs

Hello,

Every one on the forum am new here this is my first post and i wish it wan't a problem with my car but maybe some can help me.

I got a 2007 mitsubishi eclipse GS so Last night i was driving home when i can upon my exit off the high way i speed up and took the exit with high speed for fun. i know notice that my oil light come quick for about less then 2 sec. when i got home and park i open the hood to check my oil dip stick and i didn't see any no oil on it. It was middle of the night so i couldn't check under the car. This morning i went out check my car once aging i check the oil dip stick no oil on it. so i went to auto part to buy some oil so i full up wiht oil i drove around. Got home and i check the dip stick it seem i lost some oil. I check under the car i don't see no oil puddle or i don't smell no burning oil or no white smoke coming out of my muffler.

I'm debating if my Oil Pan Gasket Set that need to replace or some thing else is burning up my oil. I hope is not my piston ring but i will super screw

dose any one had this issue or has other idea what could be if there other post like this please link it in the comment so i can check it out

Thank you for time reading my post
Hey man sorry to hear your troubles check your spark plugs and see if there is oil in them when you take them out. If thats the case ur burning the oil thats why you dont see a leak. Hope it helps , just an idea.
 
1 - 3 of 3 Posts
Top