Mitsubishi Eclipse 4G Forums banner
1 - 12 of 12 Posts

·
Registered
Joined
·
24 Posts
Discussion Starter · #1 ·
'07 GT w/ about 170k miles. Repeatedly throws code P0421 Warm Up TWC (bank 1), though the Check Engine light will often go off for a day or two, then come back on with the same code. Car seems to run fine. I've replaced the Bank 1 O2 sensors; the other Bank sensors have also been replaced within the last couple of years.

So does this leave a new (and expensive) catalytic converter as the culprit? If so, which one? I'm told there are three.
Any other solutions to try first, e.g. Cataclean Fuel Additive?
 

·
Registered
2008 Eclipse GT
Joined
·
153 Posts
Cataclean didn't work for me, and I only have 112,000 Kilometres on mine. New manifolds or headers. I just bought headers as I didn't want to spend over 2 grand on new cats.
 

·
Registered
2006 GT Manual.
Joined
·
174 Posts
yes. the back side is bank 1.

headers get rid of the manivertors which have the cats built into them. you get a tune to put headers on and it does something to rectify the absence of cats.
 

·
Registered
Joined
·
24 Posts
Discussion Starter · #7 ·
yes. the back side is bank 1.
Ok then, I replaced the FRONT (Bank 2?) O2 sensors. O'Reilly sold me the wrong sensors. The mechanic told me the ones I got only fit the front, at least their electrical connectors.
Sounds like maybe I need to replace the back side and see if that fixes it. Would you agree?
 

·
Registered
2006 GT Manual.
Joined
·
174 Posts
It is a possibility. I might be wrong here but i think that the upstreams and downstreams can be interchanged. the biggest problem is usually wire length.
 

·
Registered
Joined
·
33 Posts
Literally had the exact same issue, 2007 GS with 205K on it. Cat cleaner fixed the issue. I'll probably get the manifold anyway someday soon for better performance and mpg but you said it's intermittent and almost identical to what mine was doing so I'd try it first. It's cheap and easy, and the dealer also recommended mid octane for a while, or even ongoing. Good luck
 

·
Registered
Joined
·
24 Posts
Discussion Starter · #11 ·
Literally had the exact same issue, 2007 GS with 205K on it. Cat cleaner fixed the issue. I'll probably get the manifold anyway someday soon for better performance and mpg but you said it's intermittent and almost identical to what mine was doing so I'd try it first. It's cheap and easy, and the dealer also recommended mid octane for a while, or even ongoing. Good luck
Mid octane? Really? What's the thinking behind that?
 
1 - 12 of 12 Posts
Top