Mitsubishi Eclipse 4G Forums banner
1 - 4 of 4 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
Hi guys I’m having a mental breakdown worrying about what I’ve done🫣 I went to drain and replace the trans axel fluid on my 2008 GTP 6 speed manual.

the draining went well,but when I went to fill it back up with redline MT-90 I put a little bit of it into the wrong fill hole! Where I added the oil to was the plug/hole above the actual fill hole,only a small amount of fluid made it into there, I notice it wasn’t going in anymore and it was spilling out of the fill hose at that whole…I realized this wasn’t right and stopped and revisited the forum and realized I had tried to fill into the wrong spot…..I lost a quarter bottle of redline MT-90 by doing this so now I have to go pickup some more……I’m terrible worried 🫣 that by putting a little fluid into the wrong hole I could cause serious damage to the gearbox? If anyone could help me with this it would be greatly appreciated!

I correctly added 1.5 bottles of redline mt-90 to the gear box,Heading to get another couple bottles tomorrow
 

·
Basically Stock
2009 GS Turbo. 2007 Mid Engine GT
Joined
·
7,617 Posts
Plus side: 2 quarts was never going to be enough anyway. You were always going to need a third bottle.

I'm struggling to think of what hole you could have mistaken as the filler. But also can't think of anything negative as long as it's in the trans casing and ran down to the pan. It's just gears in a bath of oil, and the spinning draws oil up. No pumps, no special chambers
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #3 ·
Plus side: 2 quarts was never going to be enough anyway. You were always going to need a third bottle.

I'm struggling to think of what hole you could have mistaken as the filler. But also can't think of anything negative as long as it's in the trans casing and ran down to the pan. It's just gears in a bath of oil, and the spinning draws oil up. No pumps, no special chambers
thanks so much sabbertooth for the reply,I can stop worrying a bit now..the fill hole that I mistaken it for was just above the fill port,the body of the port (female threads) is molded on a angle up towards the engine…the screw/plug….that came out of it was about 3 inches long…one inch or so of it haveing threads….I’ll take a picture and post it when I get home tonight,thanks again for your help!
 
1 - 4 of 4 Posts
Top