Mitsubishi Eclipse 4G Forums banner
1 - 4 of 4 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter · #1 ·
2007 mitsubishi eclipse gs 2.4l manual. My wife miss shifted at 65 miles per hour from 5 to 2nd. The car didn't go it gear but it tried and rev limited then cut off. The car started up after 5 minutes of sitting and she drove home. It now has a rough ideal and I can't figure it out. I replaced the cat bc the shop said it was that but it didn't help .I checked the timing, replaced plugs and coil packs. Checked for vacuum leaks and I haven't found anything at all wrong. The car doesn't have any codes showing either. Does anyone have any suggestions.
 

·
Basically Stock
2009 GS Turbo. 2007 Mid Engine GT
Joined
·
7,973 Posts
Ok, so it definitely went into gear. It also has no rev limiter when you money shift, as there's no fuel involved.

The good news is, 65mph in second gear isn't that crazy on the valve train if your engine is healthy with good oil. I'd regularly revved the head to 8000rpm, she'd have hit about 7600.

Now, the damage is likely that the timing slipped. Going from 5th to 2nd and dumping the clutch would be a massive load on the timing belt, and generally speaking, people don't keep up on timing belt maintenance either. I know you said you checked timing, but did you check tension, or did you remove the timing covers and actually check everything out.

If the engine wasn't healthy/running good oil, a valve guide could be fucked up and you may have an engine head rebuild on your hands.
 

·
Basically Stock
2009 GS Turbo. 2007 Mid Engine GT
Joined
·
7,973 Posts
I put on a new gates timing belt and water pump kit last year. I pulled the covers and looked at it and everything was good. I plan on doing a compression test asap.
Didn't break the pawl in the lower timing gear?
 
1 - 4 of 4 Posts
Top