Mitsubishi Eclipse 4G Forums banner
1 - 17 of 17 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
Hey all, I recently got an 06 A/T Eclipse GS. The other day I was driving home from work when I decided I would try out the sport. However it seems even when I switch over the car continues to run in automatic. I push + and - but it does nothing. Does anyone have info or ideas as to why my sportronic is not work? Thx
 

·
theBIGone
Joined
·
975 Posts
Hey all, I recently got an 06 A/T Eclipse GS. The other day I was driving home from work when I decided I would try out the sport. However it seems even when I switch over the car continues to run in automatic. I push + and - but it does nothing. Does anyone have info or ideas as to why my sportronic is not work? Thx
Man it sucks nobody has said anything yet but yeah man who knows the sportronic is all computer controlled im guessing since no clutch etc. But u sure have u tried coming to a complete stop and swtchin it over see if that works?
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #3 ·
Yeah I guess nobody really knows. Its not like I have to have it because the car still drives normally in automatic. Its just that I've been driving stick for the past 6 years and the switch to auto is odd for me now.. haha

As for switching over from a complete stop, yes I've tried.
 

·
Love My Truck
Joined
·
3,843 Posts
have the TCM checked.might be it,might not be it,but that is where i would check first.
 

·
Senior Member
Joined
·
4,111 Posts
AUTOMATIC TRANSAXLE
http://tearstone.com/eclipsefsm/2006_PS24S_MMNA_SM_PDF/GR00004100-23A.pdf

AUTOMATIC TRANSAXLE CHECKS
http://tearstone.com/eclipsefsm/2006_PS24S_MMNA_SM_PDF/GR00004100-23A.pdf

First have your OBDII read to see if there are any DTC's or pending DTC's stored.

When was the last time your trans fluid was changed?? Every 30,000 miles recommended.

Because this problem can be mechanical, hydraulic, electrical, or computer, you may need to do some reading in the above chapter in the service manual. If you have a stored DTC, give us the number and we'll do some further t-shooting. But I'm thinking it might be something simple with the shift cable needing adjustment. But if it makes you feel any better... you are the first with this type problem.
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #6 ·
Thx. When/If I have a day off from work I'll have to check into that. Like I was saying before it's not a huge concern for me at the moment since the car still drives normally and such. As for me being the first to encounter this problem.... I'm oh so thrilled..
 

·
Not Your Friendo
Joined
·
1,458 Posts
I think its the switch near the shifter. When you push it left into the +/- part, it should tell the computer "its sportronic time". Get that area checked out.

I'm gonna rule out trans fluid for this.
 

·
Senior Member
Joined
·
4,111 Posts

·
Registered
Joined
·
12 Posts
I have the same problem all of a sudden it does't switch let me shift, when i switch it over i can see the numbers but its shifting normally as it would in D, im really confused about this and how to fix this i looked at the pdf.... and i do not want to go to a dealer and get fix for hundreds of dollars as im saving for a 370z, lol.
 

·
Senior Member
Joined
·
4,111 Posts
I have the same problem all of a sudden it does't switch let me shift, when i switch it over i can see the numbers but its shifting normally as it would in D, im really confused about this and how to fix this i looked at the pdf.... and i do not want to go to a dealer and get fix for hundreds of dollars as im saving for a 370z, lol.
I'd check your OBDII to see if you have any set or pending codes first, then post those codes if any, so we can go from there.

I am not sure on this problem, but it seems like you are the only two people with this problem. It could be that you shifting cables need to be adjusted, or it could be a switch in the shifter box/lever that has gone bad.

Sorry I/we can't be of more help to you.

Edit: See/read the following:

INSPECTION PROCEDURE 15: Shift Switch Assembly System (see page 23A-331 and read on)
http://tearstone.com/eclipsefsm/2006_PS24S_MMNA_SM_PDF/GR00004100-23A.pdf

CIRCUIT OPERATION
If the select switch of the shift switch assembly is set to the sport mode, battery positive voltage will be applied to the PCM (terminal 39). If the shift switch of the shift switch assembly is set to "UP" or "DOWN" position, battery positive voltage will be applied to the PCM (terminal 32, 36).
.
COMMENT
When sport mode shift does not operate the cause is probably a malfunction of the transmission range switch circuit, shift switch assembly circuit or a defective PCM.
.
TROUBLESHOOTING HINTS (THE MOST LIKELY CAUSES FOR THIS CASE:)
•Malfunction of the transmission range switch
•Malfunction of the shift switch assembly select switch
•Malfunction of the shift switch assembly shift switch (Up)
•Malfunction of the shift switch assembly shift switch (Down)
•Damaged harness or connector
•Malfunction of the PCM
 

·
Registered
Joined
·
161 Posts
crazy how nobody else has had this issue. Sportronic works fine for me. how many miles do your cars have on them? maybe it's an ECU problem?
 

·
Registered
Joined
·
100 Posts
I just got my car ( 07 GT ) and if I am at a stop and shift over to sport, I can upshift but it won't let me downshift. Kinda weird.
 

·
Registered
Joined
·
7 Posts
I have the same problem.

Worked till my girlfriend spilled soda all over the shift area and when I dissembled to clean THOROUGHLY.. if was in some of the switches.

I think it has to do with the switch that tells the ECU that it has been switched over to Sportronic. It isn't sending the signal to the ECU to let us control it; so it still runs like an automatic but displays which gear it is in.
 

·
Registered
Joined
·
1 Posts
I have the same problem all of a sudden it does't switch let me shift, when i switch it over i can see the numbers but its shifting normally as it would in D, im really confused about this and how to fix this i looked at the pdf.... and i do not want to go to a dealer and get fix for hundreds of dollars as im saving for a 370z, lol.
Anyone found a fix for this? I just got a 2008 eclipse gt A/T and mine is doing the same thing. It worked when I got it, but it just went out in the past thousand miles. When I switch to sport it just drives normally and shows me the gear I am in it just won’t let me manually shift. Please help
 
1 - 17 of 17 Posts
Top