Mitsubishi Eclipse 4G Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
I have a 12 Spyder SE. It has been giving me starting problems for about 5 months now. I have already tried changing the battery, the starter, the battery terminals. Everything else electrical works fine. I used to be able to move the hot terminal a bit and it would start right up, and last time it happened I had someone hit the negative terminal and then my car cranked. Any ideas what the most likely problem is?
 

·
Registered
Joined
·
5 Posts
Discussion Starter #5
That’s gotta be battery, starter, starter relay, etc

check all fuses too
I forgot to add this: the other day when it did not want to start, I saw that my clock stopped getting power at about 1:02. I had driven my car to work that morning and not touched it until about 7 that evening
 

·
Registered
Joined
·
38 Posts
when you mention "hot terminal" and "negative terminal" do you mean the terminals on the battery? You shouldn't be able to move a battery terminal if it is tightened properly. If moving or hitting the terminals has an effect, they should be taken off and both terminal and battery post cleaned and replaced. If the terminals will not tighten up it might be time to replace them. If new terminals will not tighten up the battery posts may be worn down from too many cleanings in the past and then the battery will need replacing. Also with poor connections, the battery is not getting recharged properly when the motor is running.
 
1 - 6 of 6 Posts
Top