Mitsubishi Eclipse 4G Forums banner
1 - 20 of 29 Posts

·
Registered
Joined
·
5,055 Posts
Discussion Starter · #1 ·
My Traction and the Traction OFF light come on at the same time every now and then and when i look in the manual all it says is pull your car over and restart it...so ive been doin that and then the other day the check engine light came on with it. I made an appointment to get it looked at but then it turn off....It did it again and i took it to the dealership and they said its something to do with the intake. Then intake is throughing a code and in response the traction light comes on....anyone every have this happen ot hear of this happening??
 

·
Registered
Joined
·
2,584 Posts
My Traction and the Traction OFF light come on at the same time every now and then and when i look in the manual all it says is pull your car over and restart it...so ive been doin that and then the other day the check engine light came on with it. I made an appointment to get it looked at but then it turn off....It did it again and i took it to the dealership and they said its something to do with the intake. Then intake is throughing a code and in response the traction light comes on....anyone every have this happen ot hear of this happening??
Yes, it's usually a MAF sensor issue which is located in your intake. It happens to me on occasion as well, usually when I'm at the car wash...intake sucks up a little water and the lights go off...

Next time it happens, check the associated check engine light code and see what it says...

Are you boosted??? You could have some other issue...
 

·
Registered
Joined
·
5,055 Posts
Discussion Starter · #3 ·
Actually the first time the check engine light came on was in the rain, The traction light came on with the off light so i pulled over and hit a puddle and the check engine light came on. The CEL turned off a few days later but came back on out with the other lights again but it was a dry day. The dealership told me to up the stock stuff back on and come get it checked out. Another thing i thing it would be is that celluloid that was on the stock intake box with the 2 hoses. Its hard to understand want people were telling me to do with it. i have the intake manifold in the one hole then a piece of plugged hose in the other. Would this affect anything or maybe I have the wrong hose in the wrong hole. From what im reading there are a lot of intake problems out there with this car. OH AND NO IM NOT BOOSTED...YET : ) Actually i think i finally have a seller for my GS turbo kit. I told him to send out the AEM harness I had to you so he doesn't have to butcher his car wiring like I did. Do you have an email i can give him Brian.
 

·
Registered
Joined
·
2,584 Posts
Actually the first time the check engine light came on was in the rain, The traction light came on with the off light so i pulled over and hit a puddle and the check engine light came on. The CEL turned off a few days later but came back on out with the other lights again but it was a dry day. The dealership told me to up the stock stuff back on and come get it checked out. Another thing i thing it would be is that celluloid that was on the stock intake box with the 2 hoses. Its hard to understand want people were telling me to do with it. i have the intake manifold in the one hole then a piece of plugged hose in the other. Would this affect anything or maybe I have the wrong hose in the wrong hole. From what im reading there are a lot of intake problems out there with this car. OH AND NO IM NOT BOOSTED...YET : ) Actually i think i finally have a seller for my GS turbo kit. I told him to send out the AEM harness I had to you so he doesn't have to butcher his car wiring like I did. Do you have an email i can give him Brian.
he can email me at [email protected]

You need to get a CAN OBD2 code reader...it sounds like you've had a few different codes go off...it's hard to say without knowing what codes were thrown...
 

·
Registered
Joined
·
35 Posts
I got the same lights just like you said ever since I installed my intake, the first time I was at the 1/4 mile and the lights came on, i got scared and did not run anymore that day. Then i unpluged the battery and the lights were gone. The second time was also in the rain, I spinned to much the tires and got those lights. I took it to the dealer and they just erased the code.

I think this is very comon on our cars with the CAI.
 

·
The dick of JUSTICE
Joined
·
3,093 Posts
I live in rainy Vancouver, BC and I've NEVER had my Injen intake throw a code in the wet. It could be that my ECU has tuned itself for higher humidity/atmospheric pressure.

My damn Buscher intake used to do this kind of thing every 10min though.
 

·
Consumer Whore
Joined
·
185 Posts
Do you have an F/IC? I left mine on the floor for a while before I hooked it up underneath the dash and once I kicked it by accident and my number 5 injector stopped firing, gave me the exact same light display you're getting. I restarted the car and it was no problem again so I took it to Advance Auto where you can borrow a code reader (totally free, btw,) and I cleared the code, haven't had a problem since.
 

·
Registered
Joined
·
15 Posts
My car use to the same thing whenever the car got wet, water would go behind the headlight and drip water on the filter. To solve it i taped plastic underneath the headlight to stop the water from falling on the filter. That solved the problem, but then the tape wouldn't hold up after a month or two so i just changed my AEM cold air into a short ram and built a heat shield with tin, never a light on since......
 

·
Registered
Joined
·
5,055 Posts
Discussion Starter · #10 ·
but you guys got all three lights and it was something to do with the MAF...i haven't got the check engine since the dealership cleared it but other 2 lights come on every now and then and its a pain in the ass...like i said on the other site...I have started to hear a little squeek and need to check the brakes and spin the wheels to check the bearings...maybe out cars have bad bearings and could possibly have a recall issue? I know there are a lot of people getting these lights. But are these lights coming on because of the MAF does anyone know?
 

·
The dick of JUSTICE
Joined
·
3,093 Posts
yeah all 3 lights do come on but sometimes if it's an emissions related thing you'll get just the TCL lights. It's still throwing a code but the CEL doesn't light up Not really sure why Mitsubishi designed it that way.

Basically look at it as any lights turning themselves on is bad.
 

·
Registered
Joined
·
5,055 Posts
Discussion Starter · #12 ·
Yeah im the same way....the CEL only came on twice but the other 2 come on like 3-4 times a week...i just drove in hard rain for an hour so its not anything to do with that. And there are only a few people with this problem not all intake are having it...mine is custom but its still having the problems that other intake are having. so if its not water what it is...make something to do with the celluloid from the stock intake box??
 

·
E85
Joined
·
6,368 Posts
My Traction and the Traction OFF light come on at the same time every now and then and when i look in the manual all it says is pull your car over and restart it...so ive been doin that and then the other day the check engine light came on with it. I made an appointment to get it looked at but then it turn off....It did it again and i took it to the dealership and they said its something to do with the intake. Then intake is throughing a code and in response the traction light comes on....anyone every have this happen ot hear of this happening??
your boosted correct ?
 

·
Registered
Joined
·
5,055 Posts
Discussion Starter · #20 ·
yeah i do a lot of these post on my iphone too and it puts up different words and people give you shit for it...but this is a problem that a lot of people are having and its not so much the check engine but the traction lights...its not a big deal but a pain in the ass needing to put over and restart your car...then if it keeps happening you go to the dealer and they give you shit for having an aftermarket intake and try to automatically pin it on that instead of trying to find what the real problem is...they even took a picture of it so if something goes wrong they can blame the intake and not be able to use my warranty.
 
1 - 20 of 29 Posts
Top