Mitsubishi Eclipse 4G Forums banner

1 - 9 of 9 Posts

·
Registered
Joined
·
109 Posts
Discussion Starter #1
How would I go about figuring out why I'm overboosting to almost 8psi. I have a 38mm precision wastegate with a 4 psi spring in it. I have my turbosmart 1302-1002 boost controller overboost set at 6psi. I know the turbosmart solenoid works cause it click four time when I test it.I have fastwork boost cut set at cold 7psi and hot 8psi.


Sent from my SM-G960U using Tapatalk
 

·
Registered
Joined
·
109 Posts
Discussion Starter #3
Your boost controller pressure is set on top of the spring pressure
I am running it as method one. I might have to lower my spring psi. I believe the rule of thumb is if you wanted to run 10psi you would need to take away 60% which would make it a 6 psi spring you would need. I have a 3psi spring in which would roughly bring me to 5 lbs of boost which I wanted but it is overboosting to roughly 7.5 lbs of boost. So now I am wondering if I need the 4 port solenoid. I don't wanna waste money.


Sent from my SM-G960U using Tapatalk
 

·
Basically Stock
Joined
·
5,842 Posts
What does your manifold look like? Manifold design affects wastegate flow significantly.

Also, I can't find your controller when I google it. I use an E Boost Street controller with a 3 port solenoid without issue, but mine works by latency not by a boost pressure goal.
 

·
Registered
Joined
·
109 Posts
Discussion Starter #5
What does your manifold look like? Manifold design affects wastegate flow significantly.

Also, I can't find your controller when I google it. I use an E Boost Street controller with a 3 port solenoid without issue, but mine works by latency not by a boost pressure goal.
I am start to think it is my manifold. Gonna have to save up some money can't swing no 550 dollars. I was looking for a used one. I am using a e boost.


Sent from my SM-G960U using Tapatalk
 

·
Moderator
Joined
·
2,137 Posts
Saber can definitely help more as my Eclipse is not turbo but on my WRX I know the spring wastegate pressure is 8psi, so to get 16 psi you need to just set the boost controller to hold 8 psi itself, so that when it passes pressure to the wastegate, it takes another 8 psi to open the wastegate, giving u a total of 16 psi before the wastegate is actually open
 

·
Moderator
Joined
·
2,137 Posts
Is it a Subaru controller you use?

I know my tutbosmart is latency, and VAG cars use latency as well
No, it’s a TurboXS manual boost controller, just a fancy bleed valve I believe
The stock Denso one is still electrically wired up but not plumbed in
 

·
Registered
Joined
·
109 Posts
Discussion Starter #9
It was the exhaust manifold causing the overboost. I was waiting for Alex k to buy one but he never responded. So I built a new one with 2 feet of 1.6 i.d square tube 1/4 inch thick. And I made a new flange 1/4 in thick.Drilled the holes out with a 1.6 metal hole saw for 10 bucks. Wastegate tube is 1.5 id. New t4 turbo flange and 2 wastegste flanges. Now with the 1.5 psi Wastegate spring doesn't get any higher then 2psi. Now I am finally able to use my eboost controller. And yes put the wastegate right by the turbo helped. Did all of it under 100 bucks.

Sent from my SM-G960U using Tapatalk
 
1 - 9 of 9 Posts
Top